GPGMail: issues with Mail app hanging

Lindsey's Avatar

Lindsey

04 May, 2018 03:43 PM

I’m having two issues, but I believe that they are related. (1) I will initiate a draft, complete it, and send and it will appear to have been sent but there is no record in the sent folder and the message is NOT sent. There is an initial draft (first line for example) in the draft folder but not the whole message. It is not even stuck in an “outbound” folder. (2) Messages fail to load and I just get the spinning “Loading.” I think (1) is occurring when a new message is trying to come in but (2) is happening. The only resolution to either of these issues is to force quit Mail and restart my machine. I’ve tried saving drafts to my local machine only and turning off encryption on drafts but that has not solved the problem.

Expected
I’ve never had problems with the mail.app and gpg tools so this is new to me.

Additional info
I am operating on the most recent Mac OS.

macOS                   10.13.4     17E202
GPG Suite               2018.1      2083    (9658b70)
GPGMail                 3.0b4       1272    (461cda15)
GPG Keychain            1.4.2       1403    (128637e)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       900     (cead4f9)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.2       829     (943132e)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 05 May, 2018 09:26 AM

    Steve's Avatar

    Hi Lindsey,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you please download and install our latest hotfix GPG Suite and see if that solves your problem.

    Please create a new draft to rule out the possibility of the old one being corrupted in any way.

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Lindsey on 07 May, 2018 06:32 PM

    Lindsey's Avatar

    Installed and looks like I'm still having the problem, although with the drafts, it looks like it got stuck in the same way but when I did the restart, my emails had actually gone through and were in sent (and folks were responding to them, so clearly out). But still have to restart otherwise looks like it's stuck in "sending" and "loading" new emails.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • 2018-05-04_15-43_DebugInfo.gpg 78.1 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac