Export creates .asc as name of folder not key...

Simply Prince's Avatar

Simply Prince

08 Jan, 2020 10:26 PM

Which of our tools is giving you problems? The latest GPG_Suite-2019.2

Attach a screenshot of the version info for all installed components (how to: https://gpgtools.tenderapp.com/kb/faq/where-can-i-find-version-info...):

Describe your problem. Add as much detail as possible. Using GPG Keychain, select any key > Export. It then provides a Save As, usually like "Bob Bosmith (00000000) – Public". You leave that alone. Save to Desktop. for example, and it will 1) call it by the name of the folder you were going to save it to (eg Desktop.asc), and 2) it will save it in the users folder instead. Reference screenshot uploaded titled "bruh.png"

What did you expect instead I expected it to save the file by the name it provided, or any chosen, and to the location I chose.

Describe steps leading to the problem. Simply selecting Export.
I do this, per key, as I Sign the key(s) for our company and then export them to upload them to the Classic Keyservers.

Are you using any other Mail.app plugins? No additional plugins. OS was recently installed fresh, with new computer set up no integration of former backup.

Let me know if you need additional information.
I did notice this on the previous system, and my coworker can recreate it on his OS as well.

Thank you as always.

  1. Support Staff 1 Posted by Steve on 12 Jan, 2020 03:07 PM

    Steve's Avatar

    Hi Prince,

    nice hearing from you.

    I tried to reproduce the issue with 2019.2 and 2684n and was unable to do so. Tested exporting both sec/pub and pub only keys.

    This is especially odd as you already experienced this with your pre Catalina system and also a co-worker is able to reproduce.

    I'll involve Luke with this case as well and we have to figure out how to best debug this.

    I don't think it will solve this, but could you nonetheless see how the latest nightly behaves?


  2. 2 Posted by Simply Prince on 14 Jan, 2020 04:59 PM

    Simply Prince's Avatar

    Hi Steve,

    😬 Thanks for the follow up. I decided to try this again on one more unit I'm going to deploy and that one exported the Sec key fine, but not the revoke cert. Instead, it followed the same pattern of saving it one level up from where I asked it to save to and with that folders name (eg' Desktop.asc)

    I went ahead and upgraded my unit to the nightly and the export did the same.

    Feel free to let me know if you want me to verify anything, or try anything. Catalina is a very interesting OS with all of its restrictions that you bump into. Wouldn't be surprised if something there is helping this to happen.



  3. Support Staff 3 Posted by Luke Le on 14 Jan, 2020 09:20 PM

    Luke Le's Avatar

    Hi Prince,

    since we cannot reproduce the problem on our systems a remote debugging session would probably be easiest. This sounds extremely curious. Are there symlinks involved by any chance? Is GPG Keychain the only application that is misbehaving?

  4. 4 Posted by Simply Prince on 16 Jan, 2020 10:53 PM

    Simply Prince's Avatar

    Hi Luke,

    I decided to upgrade a test unit I have that had no data and key export worked fine in Mojave before I ran the upgrade to Catalina. Once I did the upgrade I was able to recreate it again.

    That being said, its the only app that seems to be odd. Let me know how you'd like to do a remote session. We're in NYC.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • Screen_Shot_2020-01-08_at_5.17.58_PM.png 174 KB
  • bruh.png 164 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac