GPG Mail: Default security method setting is ignored

sebastien.maret's Avatar

sebastien.maret

08 Jan, 2021 10:11 AM

I would like to set S/MIME as the default security method for new emails. I’ve followed the instructions in the GPG Mail FAQ:

% defaults write org.gpgtools.gpgmail DefaultSecurityMethod -int 2

and I’ve checked that the default where correctly written in the preference file:

% defaults read org.gpgtools.gpgmail | grep SecurityMethod
DefaultSecurityMethod = 2;

However for new emails the default is still PGP.

Expected
The default security method for new emails should be S/MIME if DefaultSecurityMethod is set to 2.

macOS                   11.1        20C69
GPG Suite               2020.2      2960n   (83473dc41d)
GPG Mail (loaded)       5.0         1582n   (2219fbb166)    28 trial days remaining
GPG Keychain            1.7         1654n   (2770edb546)
GPG Services            2.1         1133n   (7d5b4e0c52)
MacGPG                  2.2.25      957n    (081bef0089)
GPG Suite Preferences   2.4         1170n   (ea8c0d44b8)
Libmacgpg               1.2         940n    (edebe842d4)
pinentry                1.1.0.3     53n     (61565564c9)
  1. Support Staff 1 Posted by Steve on 08 Jan, 2021 12:06 PM

    Steve's Avatar

    Hi Sebastien,

    thanks for taking the time to report this problem.

    This is a known issue in GPG Suite 2020.2. Sadly the default is not respected. As a workaround for the time being you have to switch to S/MIME manually. We are very sorry about this. We hope to have a fix out soon.

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussion should you run into further problems or need assistance.

    Kind regards,
    Steve

  2. Steve closed this discussion on 14 Jan, 2021 07:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac