GPG Services: Decryption failed no data code = 58 when trying to decrypt a message in word doc format

laggardkernel's Avatar

laggardkernel

24 May, 2019 02:25 PM

This didn't alleviate my problem. After copying the encrypted text to a text editor (TextEdit or Sublime), the decryption still failed with the same error.

  1. Support Staff 1 Posted by Steve on 24 May, 2019 02:34 PM

    Steve's Avatar

    Hi laggardkernel,

    are you the same user as the original poster from https://gpgtools.tenderapp.com/discussions/problems/95335-decryptio... ?

    We routinely split comments from other users to keep discussions on a per case basis. So I have split your comment into a new discussion.

    Could you send a screenshot of the error message you are seeing?

    In which format did you receive the encrypted message?

    All the best,
    Steve

  2. 2 Posted by laggardkernel on 26 May, 2019 09:29 AM

    laggardkernel's Avatar

    Thanks for your reply. Sorry to bother you guys. It seems my problem is resolved after reinstalling GPGtools and upgrading it to the beta version.

    But I'd better report the problem in detail here. I didn't test the services with any received message. I just opened my text editor (sublime), typed some words, tried to encrypt and decrypt the content. The problem is, only encrypting selection succeeded, but decryption failed with error: no data code = 58. After upgrading to the beta version, the decryption succeeded.

    BTW, I'm using macOS 10.13.6.

  3. Support Staff 3 Posted by Steve on 27 May, 2019 12:55 PM

    Steve's Avatar

    Hi laggardkernel,

    thanks for the update and feedback.

    That's good to hear, that things are working fine using GPG Suite 2019.1b1.

    It would be interesting to learn if the problem returns when you re-install GPG Suite 2018.5.

    So if you have capacity feel free to give that a try and see if you are able to reproduce the initial issue.

    Best,
    Steve

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac