Decryption failed! (Unknown IPC command) Code = 275

chen.eton's Avatar

chen.eton

05 Sep, 2018 06:57 AM

Debug Log



Currently using 2018.3

This is the error I got:
Decryption failed! (Unknown IPC command)
Code = 275

I tried installing and uninstalling.
I backed up my keys and deleted .gnupg and .gnupg_pre_2.1, and importing the keys back.
Thanks in advance.

  1. 1 Posted by chen.eton on 05 Sep, 2018 07:11 AM

    chen.eton's Avatar

    I also removed homebrew

  2. Support Staff 2 Posted by Steve on 05 Sep, 2018 02:37 PM

    Steve's Avatar

    Hi Chen,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you please download and install our latest hotfix GPG Suite and see if that solves your problem. Please also restart your mac after installing the nightly build.

    In case the problem persists, please send a debug log from your affected machine: Open System Preferences > GPG Suite > Send Report. Check the box to "attach debug log". Since you already described your issue in this discussion, you don't need to add a lot of detail, but please do add the link to your existing discussion, so I can then merge your debug info with this existing discussion.

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

    PS: Adding the version info in web readable image form.

  3. 3 Posted by chen.eton on 05 Sep, 2018 03:19 PM

    chen.eton's Avatar

    Something interesting happened after more trying. It happened with both the stable and hot fix release.
    I have two keys both are RSA 4096, one made in 2015 and the other in 2018.
    When using 2018 key as sender and 2015 as the only recipient, there were no problem.
    However, when using 2015 key as sender and 2018 as the only recipient, it fails to decrypt.
    error code from 2278n:
    Decryption failed! (Decryption failed)
    Code = 152

  4. 4 Posted by chen.eton on 05 Sep, 2018 03:32 PM

    chen.eton's Avatar

    More confusing things happened:
    I was not able to send report(Report could not be sent Please create your report on our support platform instead. Click “Ok” to open the support form in your browser)
    However everything works perfectly after that,
    For example:
    decrypting my own 2015->2018 test messages
    decrypting message from others to 2018 key

  5. Support Staff 5 Posted by Steve on 05 Sep, 2018 03:47 PM

    Steve's Avatar

    This is really odd. Can you restart your mac and see if then any issues perist? Do a few tests, send some more test messages signed only, signed and encrypted.

    Also feel free to send another report after the restart. Are you able to send the report or still seeing issues? Are you using any firewall or blocking software which may be interfering with sending the report?

  6. 6 Posted by chen.eton on 07 Sep, 2018 09:09 PM

    chen.eton's Avatar

    The issue is still the same after restarts. Any thing that is send to the 2018 key will produce error 152 upon decryption.
    However I am now able to submit report, and after submitting report the issue mentioned above is resolved.

    tinfoil hat on it's the nsa's back door

  7. Support Staff 7 Posted by Steve on 08 Sep, 2018 03:49 PM

    Steve's Avatar

    Hey Chen,

    thanks for the debug log.

    Do I understand correctly that with the latest nightly build you are no longer seeing the issue in GPGServices?

    Since 2018.3 we've fixed quite a few things around Libmacgpg which works in the background and gpg which is used by GPGServices. So maybe those changes do indeed solve your issue?

  8. 8 Posted by chen.eton on 09 Sep, 2018 05:46 AM

    chen.eton's Avatar

    I just tested both 2018.3 and 2278n.
    Both produce same problem just different error codes(2018.3:error 275, 2278n:error 152)
    Nightly version(2278n) did not fix it.
    Oddly sending reports with debug logs solves the problem. If debug log was not sent the problem would persist.
    And the interesting thing is that internet connection is not needed for solving the issue by sending reports.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac