GPG Mail: Encrypted emails have incorrect line breaks with = sign

VV's Avatar

VV

10 Apr, 2019 12:43 AM

Which of our tools is giving you problems? GPG Mail v 3.0.1, Build 1330 on mac.

Attach a screenshot of the version info for all installed components (how to: https://gpgtools.tenderapp.com/kb/faq/where-can-i-find-version-info...): Attached

Describe your problem. Add as much detail as possible. Email encrypted and signed using GPGMail. Encrypted mail looks fine in sent dir or my inbox (if copied), but the other parties claim it is having formatting issues. When other parties reply to my encrypted email I can see my original email shows up with broken lines and equal symbol, =, =3D, =20, etc.

In Mail Composing I have chosen format as Rich Text.

What did you expect instead Mail shows to others in the same format I sent

Describe steps leading to the problem. Import PGP keys, Compose new email, Click encrypt and sign and send email.

Are you using any other Mail.app plugins? RWH

  1. Support Staff 1 Posted by Steve on 10 Apr, 2019 09:00 AM

    Steve's Avatar

    Hi VV,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Are you able to reliably reproduce the issue at hand with one of the parties seeing this? If so, could you find out, which OpenPGP software and exact version is used on the receiving end.

    Best,
    Steve

    PS: To benefit from the latest security fixes from apple, you may want to check for pending macOS updates in the App Store. General info about Apple security releases including the latest macOS release.

  2. 2 Posted by VV on 11 Apr, 2019 03:54 AM

    VV's Avatar

    Hi Steve,

    The other party is not using OpenPGP software. Using Symantec Encryption Desktop.

    Thanks

  3. VV closed this discussion on 12 Apr, 2019 06:58 AM.

  4. VV re-opened this discussion on 12 Apr, 2019 06:58 AM

  5. 3 Posted by VV on 12 Apr, 2019 07:00 AM

    VV's Avatar

    I've tried sending as plain text, instead of rich text format and has the same issue.

  6. Support Staff 4 Posted by Steve on 15 Apr, 2019 07:00 PM

    Steve's Avatar

    What your contact is seeing is a bug in Symantec Encryption Desktop software, which indeed is the OpenPGP software being used on the other end.

    I suggest to file a case with Symantec to make them aware of this problem.

    Feel free to keep us posted as to what they respond.

    You could ask your contact to setup Thunderbird / Enigmail on their computer for testing purposes and double check if your messages are displayed correctly using that setup.

    All the best,
    Steve

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screenshot_2019-04-10_at_01.35.33.png 78.8 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac