GPGMail: Pinentry Mac keeps harassing me for my Passphrase every five minutes

jonas eriksson's Avatar

jonas eriksson

12 Jul, 2018 12:26 PM

Pinentry Mac keeps harassing me for my Passphrase every five minutes or so, this used to be no issue whatsoever?

Expected
Being able to write emails and work without constant re-entry of my PP. I am storing it in Keychain.

macOS                   10.13.6     17G65
GPG Suite               2018.3      2223    (8d0c266)
GPGMail                 3.0b7       1319    (c2d0df0a)
GPG Keychain            1.4.4       1460    (9010342)
GPGServices             1.11.4      1013    (0b04f6c)
MacGPG                  2.2.8       916     (0ed4a99)
GPG Suite Preferences   2.1.2       997     (1a09bc7)
Libmacgpg               0.8.5       863     (0707962)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 18 Jul, 2018 01:34 PM

    Steve's Avatar

    Hi Jonas,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    GPG Suite 2018.3 comes with MacGPG 2.2.x. The migration from 2.0.x to 2.2.x results in stored OpenPGP passwords having to be re-entered. So from what you described it sounds like you had your password stored in macOS keychain earlier and now are being asked to re-enter it.

    Please see this KB-article on how to manage passwords for your keys. You could use a caching time or enable the option to store your OpenPGP passwords in macOS keychain. Then you will not be asked again for your password.

    Let me know if that answers your question and is a solution that works for you.

    Best,
    steve

  2. Support Staff 2 Posted by Steve on 18 Jul, 2018 01:37 PM

    Steve's Avatar

    EDIT: Overread your note "storing it in keychain". This is odd.

    Can you open macOS Keychain (not GPG Keychain) and search for "GnuPG". Take a note with all the passwords for the stored entries.

    Double check you have noted the correct passwords. Then remove all "GnuPG" entries from macOS Keychain. Open System Preferences > GPG Suite Preferences and make sure the option to stored the password in macOS keychain is enabled.

    Send yourself an encrypted and signed email. When being asked by pinentry for your password, enter the password for your key and the option to store in macOS keychain should be enabled.

    Does that then work and you are not asked for your password when sending another test email?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • 2018-07-12_12-26_DebugInfo.gpg 11.6 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac