10.9: GPG Config Error, gpg: can't lock networked home

tim's Avatar

tim

02 Jan, 2014 01:24 PM

GPG Keychain Access, MacGPG 1.0.2 (539183c), Build 585n
10.9.1

Please describe your problem. Add as much detail as possible.

I've tried both the 22 Oct release and now the latest with the same result. I get the GPG Config Error when I start up GPG Keychain Access. When I run gpg --list-keys from Terminal, I get:

gpg: lock not made: link() failed: Operation not supported
gpg: can't lock /Network/Servers/server.mydomain.com/<path-to-user>/.gnupg/pubring.gpg' gpg: DBG: Oops,/Network/Servers/server.mydomain.com//.gnupg/pubring.gpg.lock' is not locked
gpg: keyblock resource `/Network/Servers/server.mydomain.com//.gnupg/pubring.gpg': General error
gpg: Fatal: /Network/Servers/server.mydomain.com//.gnupg/trustdb.gpg: invalid trustdb

Yes, I am running with networked home directories.

Please describe what you did expect instead

Ummm, for GPG Keychain Access to start and to be able to create a key. For gpg --list-keys to list the keys.

I thought I had read somewhere that Keychain Access was not working due to networked home directories but I could not find that thread. And then when gpg --list-keys didn't work, I wondered if the problem was different.

If you remember, please describe the steps leading up to the problem

Really a standard installation. I have not modified any config files, leaving the defaults in place.

  1. Support Staff 1 Posted by Steve on 02 Jan, 2014 08:56 PM

    Steve's Avatar

    Hi Tim,

    let me know if thhis KB-article does help: http://support.gpgtools.org/kb/faq/networked-home-broken

    Best :)
    steve

  2. 2 Posted by tim on 02 Jan, 2014 11:06 PM

    tim's Avatar

    Hi Steve,

    My initial assessment is that the addition of lock-never fixes the problem. I knew I had seen discussion somewhere about networked home directories being a problem, but I never tried search criteria that would have found that page for me in the KB. I guess I could have looked through the FAQ, eh? ;-) Thanks!

    Are there any risks with removing the file locking?

    Tim

  3. Support Staff 3 Posted by Luke Le on 16 Jan, 2014 12:11 PM

    Luke Le's Avatar

    Hi Tim,

    unfortunately there are. If multiple threads or gnupg instances try to access the key rings at the same time, they'll very likely be destroyed. GPG Keychain Access does that and so it's very possible that you'll end up losing your keys in the process.
    You can try it, but please make sure you keep a backup of your .gnupg folder.

  4. 4 Posted by tim on 16 Jan, 2014 05:41 PM

    tim's Avatar

    Thank you for the reply. I've made a copy of the .gnupg folder.

    What is the long term solution?

    Tim

  5. Support Staff 5 Posted by Luke Le on 30 Jan, 2014 05:44 PM

    Luke Le's Avatar

    Hi Tim,

    the long term solution would be to re-implement the locking mechanism of gnupg in order to make it work on different file systems.
    We already have a ticket for that, but it will take a lot of time and thorough testing.

    You can track progress here:
    http://gpgtools.lighthouseapp.com/projects/66001/tickets/126

  6. Steve closed this discussion on 12 Feb, 2014 07:06 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac