GPG decription in MacOS saves the Password by Default

soundbubble's Avatar

soundbubble

10 Sep, 2018 07:59 AM

When deciphering encrypted files in MacOS (in the Finder), by default it wants to save the GPG password. So every time I have to UNCHECK the SAVE PASSWORD box by hand, or it is saved.

Expected
It would be normal to have the SAVE PASSWORD box UNCHECKED, and only if one wants to save it, one man rally CHECKS it. This was like that before…

Additional info
MacOS 10.12.6
GPG Keychain: 1.4.4
GPG Suite 2018.3

macOS                   10.13.6     17G65
GPG Suite               2018.3      2223    (8d0c266)
GPGMail                 3.0b7       1319    (c2d0df0a)
GPG Keychain            1.4.4       1460    (9010342)
GPGServices             1.11.4      1013    (0b04f6c)
MacGPG                  2.2.8       916     (0ed4a99)
GPG Suite Preferences   2.1.2       997     (1a09bc7)
Libmacgpg               0.8.5       863     (0707962)
pinentry                0.9.7.1     9       (db18340)
  1. 1 Posted by soundbubble on 10 Sep, 2018 10:52 AM

    soundbubble's Avatar

    In attached screen-shot one can see what I mean... the default is POSITIVE (save PW box is checked by default) for all GPG actions, MAIL, decryption of files, etc.

    It would be reasonable to make the default value NEGATIVE (box not checked).

  2. 2 Posted by soundbubble on 11 Sep, 2018 11:13 AM

    soundbubble's Avatar

    It is solved.. found this link: https://gpgtools.tenderapp.com/kb/faq/password-management

    Thank you.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • 2018-09-10_07-59_DebugInfo.gpg 9.96 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac