too few bytes & import 15 MB public keys

FRed's Avatar

FRed

30 Jan, 2012 12:25 PM

Hello,

OS X Lion 10.7.2. Latest download. Trying to decrypt some PGP text gives the gpgservices error 'too few bytes"

1/30/12 1:15:46.287 PM GPGServices: error while getting files form pboard: stream had too few bytes

This happens from wherever I try to decrypt said text (Outlook email, Outlook response, text mate, textedit...)

Also when I try to import my 15.1 MB public key file, GPG Keychain access just crashes. Crash log attached.

Finally, there is a constant message in the log about gpg-agent.conf not being found - not sure it matters.

Thanks for any help or pointers.

Fred

PS: I had probably some older gig stuff installed but I tried uninstall the gpgtools package and re-install it. Also I had PGP but removed everything manually. I have the dev stuff installed on this machine.

  1. Support Staff 1 Posted by Luke Le on 30 Jan, 2012 12:31 PM

    Luke Le's Avatar

    Hi Fred,

    if you say you have the dev stuff installed on the machine are you referring to the nightly.gpgtools.org dmgs?
    As for the public key file, 15 MB is a very big public key file but of course should be imported without problems.
    Since public keys are not necessarily sensitive would you mind attaching the file to this discussion?

    In the meanwhile if you need to import the keys urgently, you could do that using Terminal.app.
    Simply run the command:

    gpg --import path/to/key/file.asc

  2. 2 Posted by Fred on 30 Jan, 2012 02:42 PM

    Fred's Avatar

    Sorry, re. dev stuff I meant Xcode.

    And here's the public key file. gig -- import digested its 5000+ keys with no issues. Thanks!

    Thanks for the help!

  3. Support Staff 3 Posted by Luke Le on 30 Jan, 2012 02:45 PM

    Luke Le's Avatar

    For the GPGServices problem, could you please try to install the latest dev version under:

    http://nightly.gpgtools.org/GPGServices-trunk.dmg

    and let us know if it changes something?

  4. Support Staff 4 Posted by Luke Le on 30 Jan, 2012 03:36 PM

    Luke Le's Avatar

    Hi Fred,

    Also, the GPG Keychain Access version on nightly.gpgtools.org imports the keys just fine but takes a very long time to process them all (approx. 20 minutes).
    Thanks for the test file!
    We'll have to find a way to optimize the pipe communication with gpg2.

  5. Luke Le closed this discussion on 30 Jan, 2012 03:36 PM.

  6. fred re-opened this discussion on 30 Jan, 2012 05:59 PM

  7. 5 Posted by fred on 30 Jan, 2012 05:59 PM

    fred's Avatar

    Nightly GPG keychain access shows all the keys.

    Nightly GPG Services does not change anything it seems. Still getting the too few bytes error…

    Thanks for the support!

  8. Support Staff 6 Posted by Luke Le on 30 Jan, 2012 06:02 PM

    Luke Le's Avatar

    Hmm... could you post an example of the text you're trying to decrypt?
    Also, I've closed this discussion out of a mistake, sorry

  9. 7 Posted by fred on 02 Feb, 2012 05:42 PM

    fred's Avatar

    OK, here's the deal: I tried it again with TextWrangler and had no "OpenPGP" items in the service menu. Remembering the info on the web site (which I had not done before), I went in Preferences and enabled OpenPGP for Text items. This second item works. However, both in Outlook and in Textmate, I have 2 OpenPGP items (one for file? and one for text, only one is working).
    So the bug seems to be too many OpenPGP items appear in the service menu in Outlook and Textmate, making choosing the "right" one difficult...

    (This with a nightly GPGServices).

    Thanks for the support

    Fred

  10. Support Staff 8 Posted by Steve on 03 Feb, 2012 07:20 PM

    Steve's Avatar

    Hey Fred, what you experience is a known problem. We already have a ticket for this bug. Feel free to subscribe to that if you want to be notified of any changes.

    http://gpgtools.lighthouseapp.com/projects/67607/tickets/81-openpgp...

    Also, did you run the uninstaller before reinstallung the GPGServices nightly?

    All the best, steve

  11. 9 Posted by Alex on 04 Mar, 2012 09:45 PM

    Alex's Avatar

    There is a ticket now. Closing this discussion...

  12. Alex closed this discussion on 04 Mar, 2012 09:45 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac