Unable to connect to a long list of Key Servers

Jonathan33's Avatar


06 Jun, 2019 11:56 PM

I recently had to extend the expiry on my key. Since uploading it to the default server I use (pgp.mit.edu), it would seem the key has not propagated, as nearly two months later Facebook has received the updated public key from whatever key server they use (for their encrypted Facebook email notifications system). [That was in fact not what was happening. I've since discovered Facebook requires me to copy/paste in the updated key]

So I tried changing to each of the other servers in the pre-installed ones:

And a few others I tried adding in myself...

I have since updated to the current beta (1.4.7b1 1529) of GPG Keychain and the suite, and I can now connect to all of the above-mentioned except the .de one (which is fine with me). So I am posting this to simply let the developers know there may be significant issues in the way the last stable release version is handling key server connections.

Thanks for your continued great work.


  1. Support Staff 1 Posted by Steve on 07 Jun, 2019 08:26 AM

    Steve's Avatar

    Hey Jonathan33,

    thanks for taking the time to report the issues you were seeing with GPG Suite 2018.5. We are aware and have addressed several key server problems in 2019.1b1. Those fixes will be included in the next stable release.

    Try to use hkps over hkp when possible, as that uses encryption when you are using the key servers.

    All the best,

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac