GPGMail: Not finished finding public keys

Dieter's Avatar

Dieter

13 Dec, 2017 10:24 AM

Hi there,

we have encountered another issue. One of my users is sometimes getting a warning popup ( see attachment ) when he tries to forward an email. Even when he tries to forward it to himself. Trying to cancel and send it again works fine.

It happens with "2017.2" and also with nightly "2068n". We tried it with disabling "Automatically download public keys". Same result.

Have you seen that before ? Any idea what the root cause could be ?

System is a Macbook Pro running 10.13.2

Thanks
Dieter

  1. Support Staff 1 Posted by Luke Le on 13 Dec, 2017 02:38 PM

    Luke Le's Avatar

    Hi Dieter,

    welcome back :)
    Ich weiß theoretisch wann der Fehler auftritt, und das Apple dieses "Feature" in 10.13.2 hinzugefügt hat, aber wir haben ihn selbst bisher noch nie gesehen. Hat dieser User auch S/MIME Zertifikate?

  2. 2 Posted by Dieter on 13 Dec, 2017 03:17 PM

    Dieter's Avatar

    :)

    Ja beides. GPG & S/MIME. Das Forward war allerdings mit GPG. Er hat mir es mehrfach gezeigt, ist also auf seinem Rechner quasi reproduzierbar. Ich habe den Effekt aber auf meinem Rechner noch nie gesehen. Es kann sein, dass er ausser GPGMail noch andere Plugins geladen hat. Ich mach mich mal schlau wenn er ( der Chef persönlich :) ) Zeit für mich hat.

  3. Support Staff 3 Posted by Luke Le on 14 Dec, 2017 12:45 PM

    Luke Le's Avatar

    Hi Dieter,

    wir versuchen das aktuell zu reproduzieren, schaffen es aber leider nicht.
    Kannst du uns Bescheid geben, wenn du bzw. dein Chef mal Zeit hast für eine Debug Session? Um mehr zu erfahren, müsste das leider so aufwändig ablaufen wie das letzte mal bei dir.

  4. 4 Posted by Dieter on 15 Dec, 2017 11:29 AM

    Dieter's Avatar

    Bin leider erst wieder ab Mittwoch im Büro. Melde mich dann wieder.

  5. Support Staff 5 Posted by Luke Le on 15 Dec, 2017 12:21 PM

    Luke Le's Avatar

    Perfekt, danke!

  6. 6 Posted by Dieter on 23 Jan, 2018 12:26 PM

    Dieter's Avatar

    sorry für die späte antwort

    problem existiert noch immer.. gerade selbst mit 2090n erlebt.

    leider aber nicht reproduzierbar :(

  7. Support Staff 7 Posted by Luke Le on 23 Jan, 2018 12:48 PM

    Luke Le's Avatar

    Kannst du das nächste mal wenn es auftritt gleich eine Analyse File und Spindump mit dem Activity Monitor erstellen? Wär interessant um zu sehen, was Mail im Hintergrund grad macht

  8. 8 Posted by Dieter on 23 Jan, 2018 12:55 PM

    Dieter's Avatar

    spindump sehe ich Activity Monitor .. aber was genau meinst du mit Analyse File ?

    ( I'm willing to help but not smart enough ) ;-)

  9. Support Staff 9 Posted by Luke Le on 23 Jan, 2018 12:56 PM

    Luke Le's Avatar

    "Prozess analysieren" heißts hier. Wenn du Prozess selektierst und dann auf das Zahnrad Icon klickst.

  10. 10 Posted by Dieter Jablanov... on 23 Jan, 2018 12:58 PM

    Dieter Jablanovsky's Avatar

    ah. ok.. ist wohl auf dem EN gui Sample Process :)

  11. Support Staff 11 Posted by Luke Le on 23 Jan, 2018 12:59 PM

    Luke Le's Avatar

    Ah my bad. Genau Sample Process.

  12. 12 Posted by Dieter Jablanov... on 31 Jan, 2018 01:28 PM

    Dieter Jablanovsky's Avatar

    keine ahnung ob das hilft und ob ich es in der richtigen reihenfolge gemacht habe :-/

    es ist gerade wieder bei mir passiert... und während das popup auf war, habe ich diese beiden reports generiert

  13. Support Staff 13 Posted by Luke Le on 31 Jan, 2018 02:47 PM

    Luke Le's Avatar

    Hi Dieter,

    das wird immer schräger. Theoretisch müsste sich hier ein Thread finden lassen, der immer noch an den Certificates arbeitet, ansonsten macht die Meldung noch weniger sinn, aber den seh ich weder im Sample noch im Spindump. Was du mal versuchen könntest wär, das S/MIME-Zertifikat zu entfernen und erneut zu installieren.
    Wir hatten schon mehrere Fälle in denen z.b. das Erstellen eines neuen Mails sehr langsam wurde, weil der Keychain Zugriff manchmal einen Vogel hat. Bei GPGMail wird der Key nicht eingelesen, sondern lediglich die information des fingerprints an GnuPG übergeben, insofern dürfte der Check ob ein Schlüssel vorhanden ist in GPGMail nie länger als ein paar Millisekunden dauern...

  14. 14 Posted by Dieter Jablanov... on 31 Jan, 2018 02:55 PM

    Dieter Jablanovsky's Avatar

    ok.. welchen SMIME key meinst du ? den vom empfänger oder meinen oder beide ?

    die mail, bei der das passierte, ging an einen mitarbeiter. wir haben alle einen gpg UND einen smime key !

    dieter

  15. Support Staff 15 Posted by Luke Le on 31 Jan, 2018 02:59 PM

    Luke Le's Avatar

    In diesem Fall dein eigenes Zertifikat. Reproduzieren kannst du das problem weiterhin nicht oder? Und sobald du einmal auf OK klickst, kommt das nicht mehr, richtig?

  16. 16 Posted by Dieter Jablanov... on 31 Jan, 2018 03:03 PM

    Dieter Jablanovsky's Avatar

    Ja das ist korrekt. Es passiert so sporadisch, dass ich zwischendurch dachte es wäre bereits gefixt worden :D

    Ich werde dann mal mein eigenes SIME cert neu installieren und weiter beobachten.

    Nochmal zum korrekten Vorgehen beim debuggen; es reicht wenn ich den ActivityMonitor erst starte wenn ich das Popup sehe, oder ?

  17. Support Staff 17 Posted by Luke Le on 31 Jan, 2018 03:30 PM

    Luke Le's Avatar

    Genau, das sollte reichen. Wichtig ist evtl. dass du das Popup nicht bestätigst. Also einfach so schnell wie möglich, wenn du es siehst in den Activity Monitor switchen und ein Sample und Spindump erstellen.

    Vielen Dank!

  18. 18 Posted by Dieter Jablanov... on 20 Feb, 2018 01:00 PM

    Dieter Jablanovsky's Avatar

    also es scheint wirklich etwas mit dem S/MIME cert zu tun zu haben. ich hatte jetzt ne weile kein eigenes S/MIME installiert und der fehler ist in dieser zeit nicht aufgetreten.

    jetzt habe ich seit ein paar tagen wieder mein smime installiert und seit dem auch den fehler wiederholt gesehen... leider nicht daran gedacht die sample und spindumps zu machen.

    werde ich beim nächsten mal nachholen

    dieter

  19. Support Staff 19 Posted by Steve on 21 Feb, 2018 09:19 AM

    Steve's Avatar

    Danke für das Update und das ausführliche Testen. Dann würden wir spin dump und sample abwarten und einen Blick drauf werfen, sobald diese Infos noch da sind. Obskurer Fall mal wieder.

  20. 20 Posted by Dieter Jablanov... on 21 Feb, 2018 01:26 PM

    Dieter Jablanovsky's Avatar
  21. Support Staff 21 Posted by Steve on 22 Mar, 2018 02:22 PM

    Steve's Avatar

    Excuse the noise. That reply earlier today was wrong, please ignore.

  22. 22 Posted by dieter on 16 May, 2018 09:17 AM

    dieter's Avatar

    Moin. Gibt zu diesem Thema irgendwas neues ?

    Es stellt sich heraus, dass dieser Fehler nicht ganz unkritisch ist. Wenn aus versehen deshalb eine Mail mit sensitivem Inhalt unverschlüsselt verschickt wird, kann es u.U. zu hohen Konventionalstrafen für uns kommen.

    Wir sollten deshalb irgendwie sicherstellen, dass das nicht passierten kann. Z.b. erst garnicht die Option "Ja ich will die Mail dann eben unverschlüsselt senden" vorschlagen, sondern die Mail einfach garnicht verschicken.

    Könntet Ihr das so ändern ?

  23. Support Staff 23 Posted by Luke Le on 18 May, 2018 12:35 PM

    Luke Le's Avatar

    Hi Dieter,

    vorerst leider nicht nein. Wenn wir das Update für efail draußen haben, schau ich mir das Problem nochmal an. Hab eine mögliche Lösung die mir vorschwebt, aber echt blöd, dass das nie bei uns auftritt.

    Wir haben uns bereits überlegt einen "Strict-Mode" einzuführen, der dann E-Mails nie umverschlüsselt rauslassen würde.

  24. 24 Posted by dieter on 18 May, 2018 12:52 PM

    dieter's Avatar

    danke.
    hatte den fall gestern wieder. hatte dann testweise auf "OK" gedrückt, aber die email kam trotzdem verschlüsselt beim empfänger an. also wenn man sich darauf veralssen könnte, dass es immer so ist, wäre das ja ok.

  25. Support Staff 25 Posted by Luke Le on 18 May, 2018 12:55 PM

    Luke Le's Avatar

    Ja das ist leider so. Da es sich um ein Timing Problem handelt welches wirklich eine Sekunde (oder noch kürzer) später "aufgelöst" ist, wird E-Mail auch gleich drauf dann verschlüsselt geschickt. Nur löst das natürlich komplette Unsicherheit aus.

  26. Steve closed this discussion on 17 Oct, 2018 06:28 PM.

  27. Dieter Jablanovsky re-opened this discussion on 02 Apr, 2019 03:01 PM

  28. 26 Posted by Dieter Jablanov... on 02 Apr, 2019 03:01 PM

    Dieter Jablanovsky's Avatar

    Hi Luke,

    hatte heute ein Problem lösen können, das mir seit letzter Woche Kopfzerbrechen machte.

    Nach dem Upgrade auf Mojave 10.14.4, musste unsere Chefin immer 10-30 Sekunden warten, wenn sie eine neue Email schreiben wollte. So lange blieb nämlich der OpenPGP/SMIME Button "gray" und die "encrypt" & "sign" Buttons verschwunden.

    GPG Plugin disablen hat keine Besserung gebracht.

    Nach einigen Versuchen und "dtruss" der Mail.app stellte sich heraus, dass wohl der Zugriff auf die Login Keychain sehr langsam ist.

    Also Login-Keychain "weg gemoved" ... Mail.app neu gestartet... bingo... die Buttons waren sofort da... und PGP-Keys konnten sofort benutzt werden.

    Also Keychain wieder installiert und angesehen. Es befanden sich hunderte wenn nicht tausende von iMessage signing und encryption keys in der Login-Keychain. Hmmm....

    Alle iMessage Keys aus der Login Keychain gelöscht. Mail.app restartet. ... Bingo2.. alles ist wieder Snappy.

    Im Web ist einiges darüber zu lesen. Einige meinen es sei ein Bug seit ElCapitan.

    Egal... DAS Problem ist mal gelöst. Evtl. erscheinen ja jetzt auch nichtmehr diese "not finished finding public key" popups.. we will see.

    Nur mal so als Denkanstoss über mögliche Gründe bei der Suche nach der Ursache.

    Grüsse
    Dieter

  29. 27 Posted by Dieter Jablanov... on 02 Apr, 2019 03:24 PM

    Dieter Jablanovsky's Avatar

    haha... almost... hatte in meiner keychain auch ne menge iMessages gelöscht... hat aber wohl nicht das problem gelöst. Wobei.... hatte glaube ich nicht Mail neu gestartet... hmm.

    gerade bekommen :)

  30. Support Staff 28 Posted by Steve on 03 Apr, 2019 01:40 PM

    Steve's Avatar

    Danke für den Report. macOS Keychain verschluckt sich immer mal. Wir hören solche Probleme seit Beginn dieses Projektes, also schon eine Weile.

    Leider hat sich bzgl. dem Problem mit dieser falschen Fehlermeldung noch nichts getan. Darf ich nochmal Fragen, mit welcher Frequenz du diesen Fehler siehst? Ich sehe den bei mir auch, aber recht selten.

  31. 29 Posted by Dieter Jablanov... on 03 Apr, 2019 02:00 PM

    Dieter Jablanovsky's Avatar

    Ja, bei mir auch sehr selten und nicht reproduzierbar.

    Ich hatte ja kurzzeitig gehofft, dass es mit der Bereinigung der KeyChain auch gegangen ist... wurde aber schon direkt nachdem ich Euch die Email geschickt hatte wieder auf den Boden der Realität geholt.

    Manchmal passiert es wochenlang nicht... und dann wieder mehrmals am Tag.

    Als weiteres Puzzelstück: wir haben für unsere User PGP und SMIME Keys. Also S/MIME natürlich in der KeyChain und GPG im gpg keyring.

    Sobald ich weitere Puzzelstücke habe melde ich mich wieder.

    Dieter

  32. Support Staff 30 Posted by Steve on 03 Apr, 2019 02:07 PM

    Steve's Avatar

    Das scheint zumindest davon unabhängig zu sein. Ich hab hier nur OpenPGP im Einsatz und seh es dennoch (ähnlich wie bei euch, monatelang nix und dann wieder mal).

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • PastedGraphic-1.png 84.9 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac