Preferred algorithm in GPG Keychain does not work.

's Avatar


08 Aug, 2013 07:36 AM

GPGKeychain 1.1.2 (507), OS 10.6.8.
If I right-klick on my key and select "preferred algorithm". I get an alert window that this is currently not implemented.
It definitely worked with the pre-Suite version some weeks ago.

By the way, how can I select the algorithm used for "encrypt with password" in GPGServices? Is the symmetric crypto algorithm chosen at GPGKeychain used?? On the other hand there (GPGKeychain) it is associated with a key pair but "encrypt with password" should be independent of such a pair so this makes no sense.

  1. Support Staff 1 Posted by Steve on 10 Aug, 2013 10:54 AM

    Steve's Avatar

    Hi Yedel,

    thanks for taking the time to report this problem. We are aware of this and it's a current shortcoming due to restructuring the framework behind GPG Keychain Access.

    It will be re-implemented. For the time being this option is only accessible via the terminal.

    We've a ticket for this problem:

    Should this discussion get closed, it will be re-opened as soon as the ticket is closed so you'll receive a notification. Feel free to open a new discussions should you run into further problems or need assistance.

  2. Steve closed this discussion on 27 Aug, 2013 09:20 AM.

  3. Support Staff 2 Posted by Steve on 07 Feb, 2014 05:09 PM

    Steve's Avatar

    Hi Yedel,

    this ticket is now fixed. If you want to test the fix, please download the latest nightly from here:

    Should the problem persist, please re-open this discussion. If you have other questions you can open a new one any time.

    Best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  4. Steve closed this discussion on 07 Feb, 2014 05:09 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac