Wrong GPGPreferences installed on 10.6.8?

peter's Avatar


29 Jul, 2013 12:03 PM

I ran the installer on my 10.6.8 system. It didn't install the Mail bundle (and I now see that will be fixed today).

BUT it also seemed to install the wrong GPGPreferences. When I click on the GPG Preferences icon in System Preferences it says:
"You can’t open GPGPreferences preferences because it doesn’t work on an Intel-based Mac."

  1. Support Staff 1 Posted by Steve on 29 Jul, 2013 08:38 PM

    Steve's Avatar

    Hi Peter, thanks for the feedback. We are in the midst of fixing this and hope to release a working version soon.

    Sorry for this inconvenience. We'll update this discussion as soon as we have a working version available.

    All the best, steve

  2. Support Staff 2 Posted by Luke Le on 31 Jul, 2013 09:50 PM

    Luke Le's Avatar

    Hi Peter,

    we've just released a new version of GPG Suite which includes a fix for your
    Please download it from: https://s3.amazonaws.com/gpgtools/GPG%20Suite%20-%202013.07.31.dmg

  3. 3 Posted by peter on 31 Jul, 2013 10:22 PM

    peter's Avatar

    Hi Luke
    I installed it but still have exactly the same problem with GPG Preferences:

    "You can’t open GPGPreferences preferences because it doesn’t work on an Intel-based Mac."


  4. Support Staff 4 Posted by Luke Le on 01 Aug, 2013 11:33 AM

    Luke Le's Avatar

    Hi Peter,

    I just checked the Apple Forums and apparently this is a problem which might not be related to a specific software.
    Could you try to run OnyX? That's a program that cleans your system, repairs permissions and most of the time helps to solve such problems.


    The following article shows you the recommended settings for OnyX:

    Please ignore everything that's written on that page, only the screenshot is important.

  5. 5 Posted by peter on 01 Aug, 2013 02:30 PM

    peter's Avatar

    Hi Luke
    I tried onyx but it made no difference to the GPGPreferences (although it did screw up some of my other system preferences!) :-(

  6. Support Staff 6 Posted by Luke Le on 01 Aug, 2013 02:32 PM

    Luke Le's Avatar

    Hmm… would you mind coming into our live chat, so we can have a closer look at this?

  7. 7 Posted by Olivetti on 02 Aug, 2013 08:20 PM

    Olivetti's Avatar

    Hi Luke,
    same here on a MacBook 1.1/10.6.8 as described in Peters Post #4.
    I also ran "update_dyld_shared_cache -root / -force".
    But GPGPrefs from GPGTools-2013.5.20 doing fine.

  8. Support Staff 8 Posted by Luke Le on 02 Aug, 2013 08:26 PM

    Luke Le's Avatar

    Hi Olivetti,

    could you please open Console.app and check for any errors related to this issue in there?
    This error messages is such non sense that it's really strange, there's not more to be found on the cause.

  9. Support Staff 9 Posted by Luke Le on 02 Aug, 2013 08:33 PM

    Luke Le's Avatar

    Now this sounds kinda strange, but were you opening a different third-party preference pane before trying to use GPGPreferences?

    I've found this somewhere on a forum
    " Ok turns out that you had opened a 32bit pref pane which made SystemPreferences run in 32 bit mode, you have to close SystemPreferences in order to open the 64 bit only MagicPrefs pref pane.

    GPGPreferences is also 64bit only.
    Also, could you please tell me what kind of Mac this problem is appearing on?

    Sorry for the troubles!

  10. 10 Posted by Olivetti on 02 Aug, 2013 08:50 PM

    Olivetti's Avatar

    No Problem, it's on a MacBook 1,1/10.6.8, which is the first one and it's 32bit only.
    http://en.wikipedia.org/wiki/MacBook#Model_specifications - Early 2006 with a Core Duo.
    As i told in post #8, i can run GPGPrefs from GPGTools2013.5.20 with no Problems (i switch back and forth with "mv" in /Library/PreferencePanes).
    If GPGPref is 64bit only, then the error has been found.


    02.08.13 22:58:06    System Preferences[38715]   .scriptSuite warning for result type of command 'timedLoad' in suite 'SystemPreferences': the type NSNumber ('long') doesn't match the result Apple event code ('doub').
    02.08.13 22:58:06   System Preferences[38715]   Error loading /Library/PreferencePanes/GPGPreferences.prefPane/Contents/MacOS/GPGPreferences:  dlopen(/Library/PreferencePanes/GPGPreferences.prefPane/Contents/MacOS/GPGPreferences, 265): no suitable image found.  Did find:
        /Library/PreferencePanes/GPGPreferences.prefPane/Contents/MacOS/GPGPreferences: mach-o, but wrong architecture
    02.08.13 22:58:06   System Preferences[38715]   NSPrefPaneBundle instantiatePrefPaneObject: principalClass is nil.
  11. Support Staff 11 Posted by Luke Le on 02 Aug, 2013 09:36 PM

    Luke Le's Avatar

    Yes it is.
    I've just reverted it to be 32bit too again.
    Could you please try the version you'll find attached and us know if that works?
    Will be officially fixed in the next release.

  12. 12 Posted by peter on 03 Aug, 2013 07:23 AM

    peter's Avatar

    Hi Luke
    sorry I've been away at a client site for a while. I'm running on a 32bit iMac. So that sounds like the problem.
    I headed over to the new discussion you split off. I don't speak German but it appeared that the GPGPreferences-1.0.2-5.dmg worked for Olivetti, so I downloaded that and it worked for me too.

  13. Support Staff 13 Posted by Steve on 03 Aug, 2013 06:31 PM

    Steve's Avatar

    Hi Peter,

    Perfect. Glad, this is solved for you. And thanks for the feedback. This fix will be contained in the next stable release.

    I'm closing this discussion. If you need further assistance or have questions open a new discussion any time.

    Best, steve

  14. Steve closed this discussion on 03 Aug, 2013 06:31 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac