(Re-) Activation fails in MacOS 10.14.3

Marc Scholl's Avatar

Marc Scholl

29 Jan, 2019 07:15 AM

Hi there,

every time I start (Mac) Mail, GPG Suite pops up with a registration window. If I past in my license key, it reports an "unknown problem". If I remember correctly, this occurs since the last MacOS update (10.14.3), but I'm not 100% sure.

Expected
Should not even ask again, but certainly should accept the key.

macOS                   10.14.3     18D42
GPG Suite               2018.5      2368    (6f26711)
GPG Mail                3.0.1       1330    (807c323e)  Trial not yet started
GPG Keychain            1.4.6       1514    (560b5a9)
GPG Services            1.11.6      1056    (ad0c960)
MacGPG                  2.2.10      921     (b487092)
GPG Suite Preferences   2.1.4       1077    (ad934a9)
Libmacgpg               0.8.7       895     (78f424a)
pinentry                1.1.0       10      (1ff8803)
  1. Support Staff 1 Posted by Luke Le on 29 Jan, 2019 08:10 AM

    Luke Le's Avatar

    Hi Marc,

    we are very sorry you are experiencing issues with GPG Suite.
    We are seeing this kind of error with users who are using CleanMyMac. For some yet unknown reason, CleanMyMac seems to delete some very important files which are necessary to start one of our services.

    Please re-install the latest GPG Suite (no need to uninstall first) and everything will work again as expected.

  2. 2 Posted by Marc H. Scholl on 29 Jan, 2019 10:01 AM

    Marc H. Scholl's Avatar

    Yep! That solved it, thanks!
    --Marc

    On Tue, Jan 29, 2019 at 09:10h, Luke Le <[email blocked]> wrote (with possible deletions):

  3. Support Staff 3 Posted by Steve on 30 Jan, 2019 11:12 AM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    Steve

  4. Steve closed this discussion on 30 Jan, 2019 11:12 AM.

  5. Support Staff 4 Posted by Steve on 13 Mar, 2019 04:11 PM

    Steve's Avatar

    CleanMyMac v4.3.0 has been released and it should prevent this problem from happening again.

    Thanks to MacPaw for taking care of this.

    Best,
    Steve

  6. Steve closed this discussion on 13 Mar, 2019 04:11 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac