GPG Mail: GPGMail fails leaving Mail entirely unusuable

jimcavoli's Avatar

jimcavoli

16 Jan, 2019 06:23 PM

When setting up a new work machine, running macOS Version 10.14.2 (18C54) and Mail Version 12.2 (3445.102.3) with GPGMail 3.0.1 / 1330 (807c323e), I found that the GPGMailLoader.mailbundle would prevent Mail from starting when present. I did not have the ability to select the plugin from the settings in Mail because Mail would technically launch but freeze immediately, without loading any windows, and with everything in the menu bar’s dropdowns grayed out.

Expected
I would expect to be able to follow the directions and have GPGMail load up and run in my Mail client on the newer machine.

Additional info
I have since held back my old machine (persona and work alternate) back from updates, and it is still running macOS Version 10.14 (18A391) and Mail Version 12.0 (3445.100.39) but also with the same GPGMail version 3.0.1 / 1330 (807c323e). It loads GPGMail with no issues, but I’m not sure at what point in the upgrades in between this would have emerged as a potential problem.

macOS                   10.14.2     18C54
GPG Suite               2018.5      2368    (6f26711)
GPG Mail                3.0.1       1330    (807c323e)  3 trial days remaining
GPG Keychain            1.4.6       1514    (560b5a9)
GPG Services            1.11.6      1056    (ad0c960)
MacGPG                  2.2.10      921     (b487092)
GPG Suite Preferences   2.1.4       1077    (ad934a9)
Libmacgpg               0.8.7       895     (78f424a)
pinentry                1.1.0       10      (1ff8803)
  1. Support Staff 1 Posted by Steve on 23 Jan, 2019 07:09 PM

    Steve's Avatar

    Hi Jim,

    we are very sorry for your bad experience with GPG Suite. Please excuse the slow response.

    Unfortunately this happens due to a bug in macOS Mail on Mojave. We have filed the bug with Apple as rdar://45552251 but it is unclear how long it will take them to resolve the issue.

    Following are the steps that should fix this problem:

    • Close Mail.app
    • Open Terminal and run the following command:

    sudo rm -rf ~/Library/Containers/com.apple.mail/Data/DataVaults

    • Open Mail.app

    We recommend to use their feedback form to inform Apple about this problem and ask them kindly to consider investing the time to fix this bug. It may help to add the rdar number, so they know which issue you are referring to.

    Please let us know if that worked.

    Best regards,
    Steve

    PS: We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussions should you run into further problems or need assistance.

  2. 2 Posted by jimcavoli on 23 Jan, 2019 09:07 PM

    jimcavoli's Avatar

    That (plus re-adding the GPGMailLoader.mailbundle to ~/Library/Mail/Bundles) totally resolved the startup issue and allowed me to go into my mail preferences and enable GPGMail.

    Thanks so much!

  3. jimcavoli closed this discussion on 23 Jan, 2019 09:07 PM.

  4. Steve re-opened this discussion on 23 Jan, 2019 10:34 PM

  5. Support Staff 3 Posted by Steve on 23 Jan, 2019 10:34 PM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    Steve

  6. Steve closed this discussion on 23 Jan, 2019 10:34 PM.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac