GPG Mail: GPGMail not showing in Apple Mail

Jim Macak's Avatar

Jim Macak

29 Dec, 2018 09:15 PM

I recently installed GPG Suite 2018.5 and I can’t see any evidence of GPGMail’s encryption/signing options when I open a new composing window to send a new email. I do not see the “Manage Plug-ins… button in Mail > Preferences > General so I can’t try the “trick” to enable GPGMailLoader.mailbundle. I have moved the GPGMailLoader.mailbundle out of and back into the folder at /Library/Mail/Bundles as described in another message and this had no effect. I’ve reinstalled GPG Suite 2018.5 and have restarted the computer to no effect. There is no DataVaults folder in ~/Library/Containers/com.apple.mail/Data/ to try and remove as suggested in another message.

Expected
To see and be able to use the two additional GPG buttons in a new Mail composing window.

Additional info
macOS Mojave 10.14.2, iMac (Retina 5K, 27-inch, Late 2015)
The other parts of GPG Suite seem to work fine.
I have been able to encrypt and sign emails using the Enigmail add-on in Mozilla Thunderbird.

macOS                   10.14.2     18C54
GPG Suite               2018.5      2368    (6f26711)
GPG Mail                3.0.1       1330    (807c323e)  29 trial days remaining
GPG Keychain            1.4.6       1514    (560b5a9)
GPG Services            1.11.6      1056    (ad0c960)
MacGPG                  2.2.10      921     (b487092)
GPG Suite Preferences   2.1.4       1077    (ad934a9)
Libmacgpg               0.8.7       895     (78f424a)
pinentry                1.1.0       10      (1ff8803)
  1. Support Staff 1 Posted by Steve on 29 Dec, 2018 09:22 PM

    Steve's Avatar

    Should you be available, could you hop on our live chat here:
    https://www.hipchat.com/gyyOrLdWt

    We can't promise a solution, but we'd like to inspect this problem in more detail. When joining the live chat, please post the URL of this discussion so we know which case you are contacting us about.

    All the best
    steve

  2. Support Staff 2 Posted by Steve on 29 Dec, 2018 09:42 PM

    Steve's Avatar

    in case that's not possible, could you please send a screenshot of Mail.app > Preferences.

  3. Support Staff 3 Posted by Luke Le on 29 Dec, 2018 10:02 PM

    Luke Le's Avatar

    Hi Jim,

    if you don‘t see that button, it means a setting for macOS Mail is missing, which is normally set by our installer but in your case is not for some reason.
    Please run the following command in Terminal:

    defaults write com.apple.mail EnableBundles -bool YES
    

    After that, restart macOS Mail and you should see the manage plugins button. From macOS Mojave on, Plugins only ever work if enabled via the „Manage Plug-ins“ dialog.

    Hope that helps.

  4. 4 Posted by James Macak on 29 Dec, 2018 11:08 PM

    James Macak's Avatar

    Luke and Steve,

    Thanks for the super quick replies. Sorry I missed the chat invitation.

    The Terminal command of "defaults write com.apple.mail EnableBundles -bool YES" worked to alleviate the problem.

    After issuing the command, I restarted the computer and opened Apple Mail, opened its General Preferences tab and now the “Manage Plugins…" button was present.

    I turned on the GPGMailLoader.mailbundle, Mail quit and restarted and now I have the encrypt and sign buttons present as they should be in a new compose window.

    Thanks again for the quick resolution to this issue!

    Cheers,

    Jim

  5. Support Staff 5 Posted by Steve on 29 Dec, 2018 11:15 PM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    Steve

  6. Steve closed this discussion on 29 Dec, 2018 11:15 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac