GPG Services: Code:38 Failed Decryption

Alex 's Avatar


15 Nov, 2018 04:53 PM

Hello. I have been using GPG Suite for a 1 year now and since I updated to the newest version, I continue to receive this error. It happens when I attempt to decrypt something that I or someone else has encrypted.It's been like this for the past week, I tried to fix it by uninstalling GPG suite and then re-installing it but it still won't work. Is there anyway of fixing this?

  1. Support Staff 1 Posted by Steve on 17 Nov, 2018 05:29 PM

    Steve's Avatar

    Hi Alex,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Do you remember which version of GPG Suite you were running prior to the update? Does this problem persist after restarting your mac?

    Let's test gpg encryption and decryption in the terminal.

    1. click spotlight at the top right menubar and type 'terminal'
    2. open by pressing enter
    3. in the new terminal window
    4. paste the following without the ' 'gpg2 -ae --default-recipient-self <<<OK'
    5. a PGP message will be created
    6. paste the following without the ' 'gpg2 -ae --default-recipient-self <<<OK | gpg2 -d'
    7. you will be asked for your password (if your password is still in the cache or stored in macOS keychain you will not be asked)
    8. when everything is fine you should see the word "OK" in your terminal - in that case decryption worked as expected

    Should the issue persist, please send a debug log from your affected machine: Open System Preferences > GPG Suite > Send Report. Check the box to "attach debug log". Since you already described your issue in this discussion, you don't need to add a lot of detail, but please do add the link to your existing discussion, so I can then merge your debug info with this existing discussion.


  2. Steve closed this discussion on 18 Sep, 2019 03:56 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac