GPG Suite Preferences: Setting options to not use passphrase cache ineffective

Robert Hyerle's Avatar

Robert Hyerle

08 Nov, 2018 11:04 AM

See discussion topic: https://gpgtools.tenderapp.com/discussions/problems/89026-remember-...

Expected
No or time-limited caching of passphrase for symmetric decryption. Got: always uses cached passphrase.

macOS                   10.13.6     17G3025
GPG Suite               2018.5      2368    (6f26711)
GPG Mail                3.0.1       1347    (39fef82b)  Trial Expired
GPG Keychain            1.4.6       1514    (560b5a9)
GPG Services            1.11.6      1056    (ad0c960)
MacGPG                  2.2.10      921     (b487092)
GPG Suite Preferences   2.1.4       1077    (ad934a9)
Libmacgpg               0.8.7       895     (78f424a)
pinentry                1.1.0       10      (1ff8803)
  1. 1 Posted by Robert Hyerle on 08 Nov, 2018 05:36 PM

    Robert Hyerle's Avatar

    With the settings mentioned above, re-encrypting ("-ca") seems to have cleared whatever cache was being used: I now get prompted for a passphrase at each decryption command ("-d") use.

  2. Support Staff 2 Posted by Steve on 14 Nov, 2018 04:54 PM

    Steve's Avatar

    Hi Robert,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Sounds like you where able to solve your issue already.

    In System Preferences > GPG Suite Preferences there is an be an option to clear the cache. And simple UI options to use neither macOS keychain nor caching time.

    Glad, this is already solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    Steve

  3. Steve closed this discussion on 14 Nov, 2018 04:54 PM.

  4. Robert Hyerle re-opened this discussion on 14 Nov, 2018 05:14 PM

  5. 3 Posted by Robert Hyerle on 14 Nov, 2018 05:14 PM

    Robert Hyerle's Avatar

    Thanks. Fine to close as I have things working and the problem may be hard to re-produce. However, the Preference settings you mention below
    are exactly the ones that did not work: turning off all caching, macOS keychain, using the “delete” button .. still kept my passphrase cached somewhere.

    — robert

  6. Support Staff 4 Posted by Steve on 14 Nov, 2018 05:15 PM

    Steve's Avatar

    Are you able to somehow still reproduce this behavior?

  7. 5 Posted by Robert Hyerle on 14 Nov, 2018 05:23 PM

    Robert Hyerle's Avatar

    No. Turning on and off caching is working correctly now. Previously, I could only nudge the cache to forget by re-encrypting the file. Now that it is back working, I have not been able to break it. Another bug hiding away for another day.

    thanks,
    — robert

  8. Support Staff 6 Posted by Steve on 14 Nov, 2018 05:26 PM

    Steve's Avatar

    OK, please keep an eye on this and do let us know should this faulty behavior return.

  9. Steve closed this discussion on 14 Nov, 2018 05:26 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac