undo button in gpg keychain access app

vka's Avatar


08 Jun, 2013 10:43 AM

* Software name and version:
GPG Keychain Access 1.0 (196)
* OS X version: (e.g. 10.7.2)
* GPGTools Installer date:
**What steps will reproduce the problem? Please be as specific as possible.**

 1. Create a new key with default settings: the key will be exported to the default server immediately
 2. Press the undo button: the key will be destroyed from the keyring
 3. No undo of undo possible (no backup seems to exist). Key revocation not possible!

**What do you expect to see? What do you see instead?**

* I want to see the undo button removed and make private key deletion always behind a separate menu and with safeguard dialogue
* Instead of having accidentally publishing a key I cannot access a minute later
* Have you already tried running the latest nightly of the [GPGTool Installer](http://nightly.gpgtools.org/)?

  1. Support Staff 1 Posted by Steve on 16 Jun, 2013 05:07 PM

    Steve's Avatar

    Hi vka,

    I tried to reproduce this problem and when I click undo, the new key is indeed gone. But when I click undo again, the key re-appears.

    We've created a ticket to display a warning. Please subscribe to the ticket if you want to be notified of changes being made in regards to this issue:


    Hope this will prevent other users from running into this.

    Best, steve

  2. Steve closed this discussion on 04 Jul, 2013 08:15 AM.

  3. Steve closed this discussion on 21 Oct, 2014 02:14 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac