GPG Build Failed Error 65

wmsrite's Avatar


23 Oct, 2018 02:50 PM

Which of our tools is giving you problems? GPGTools

Attach a screenshot of the version info for all installed components (how to:

Describe your problem. Add as much detail as possible. While trying to build GPGTools from the source code I cloned from the GitHub repo I keep getting build failures in both terminal and XCode. In terminal the error code 65 describes the problem this way:
The following build commands failed: CompileC /Users/wmsrite/ascript/GPGMail/build/ /Users/wmsrite/ascript/GPGMail/Source/GPGException+GPGMail.m normal x86_64 objective-c (1 failure) make: *** [GPGMail.mailbundle] Error 65

I have cloned and built the Libmacgpg dependency into the /GPGMail/Dependencies folder and that build was successful (building the Libmacgpg worked fine)

I have GnuPG installed and updated. I've been able to get GPGSuite installed when I use the .dmg package installer. But I wanted to try it via the open-source version. I uninstalled GPGSuite prior to my attempts to compile via the source code from github.

What did you expect instead I expected a successful build

Describe steps leading to the problem. installed and updated GnuPG via brew
cloned the GPGTools repo from
cloned the Libmacgpg to the GPGMail/Dependencies folder
did a build of Libmacgpg via "make" command in terminal
switched to the GPGMail directory and tried to build via "make" command in terminal
got the error
Opened Xcode and imported the source code into Xcode
tried to build via Xcode and got this error:
'Libmacgpg/Libmacgpg.h' file not found

Are you using any other plugins? No

  1. 1 Posted by PMellier on 25 Oct, 2018 09:00 AM

    PMellier's Avatar

    Same issue with me, but on macOS 10.13.6

  2. 2 Posted by Shu on 06 Feb, 2019 09:55 AM

    Shu's Avatar


    The readme in the repo says MacOS Sierra is not supported yet, let alone Mojave.

    Have the same issue anyway.

  3. 3 Posted by Shu on 06 Feb, 2019 10:33 AM

    Shu's Avatar

    Hi again.

    Actually you need to checkout mojave branch. I build it successfully, but the Manage Plug-Ins option is missing from the General Preferences page in Mail.

  4. 4 Posted by Shu on 06 Feb, 2019 06:01 PM

    Shu's Avatar

    Well, Manage Plug-Ins is simple, discussed here:
    tldr: sudo defaults write "/Library/Preferences/" EnableBundles 1

    However gives me Libmacgpg not found on your system

  5. Luke Le closed this discussion on 18 Mar, 2019 12:42 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac