GPGMail: Previous Emails Not Viewable After Upgrade to 2018.4

Reid Gravelle's Avatar

Reid Gravelle

08 Oct, 2018 10:46 PM

The other day I upgraded GPG-Suite after I was notified that an update was available. From then on whenever I clicked on a message that I had sent that I had signed with a previous version of GPGMail instead of being able to see the message all I would see is “Loading” with a spinner in front of it. I could wait five minutes and it would still be “Loading”. Other messages would come back up instantly.

I uninstalled version 2018.4 and installed 2018.3 and all of the messages are viewable again with no delay in display.

The message to be displayed.

Additional info
I’m running on macOS 10.12.6 with all of the available updates, except iTunes. Mail is running Version 10.3 (3273).

macOS                   10.12.6     16G1510
GPG Suite               2018.3      2223    (8d0c266)
GPGMail                 2.7.3       1268    (b7a4d043)
GPG Keychain            1.4.4       1460    (9010342)
GPGServices             1.11.4      1013    (0b04f6c)
MacGPG                  2.2.8       916     (0ed4a99)
GPG Suite Preferences   2.1.2       997     (1a09bc7)
Libmacgpg               0.8.5       863     (0707962)
pinentry           9       (db18340)
  1. Support Staff 1 Posted by Steve on 09 Oct, 2018 08:11 AM

    Steve's Avatar

    Hi Reid,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you please download and install our latest hotfix GPG Suite and see if that solves your problem.

    All the best,

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Reid Gravelle on 09 Oct, 2018 04:04 PM

    Reid Gravelle's Avatar

    Hi Steve,

    Thanks for getting back to me so quickly.

    I downloaded the October 1, 2018 nightly build (2332n) it it was much better. I could view my messages. The only problem I encountered was if I had a message that contained a PDF file then any attachments would not show.

    I send myself interesting recipes so that I don’t lose them. (I used to bookmark them but sites go down or sites get reorganized and URL change and I’d lose the recipe so I started to email the recipe to myself.) The format of the email is the PDF obtained by “printing” the web page and from the bottom left drop down menu selecting Mail PDF, a few blank links, an image of the final result, a few more blank lines, and a link to the recipe. All that comes up with the nightly build is the blank lines and the URL. The 2018.4 release just had “Loading” so it is an improvement. If the message just has an image it showed correctly. I didn’t think to test with just a PDF file. Sorry.

    I haven’t updated anything else on my machine. Before installing the nightly build I opened the dmg file for the 2018.3 release and ran the uninstall app.

    Thanks again,

  3. Support Staff 3 Posted by Steve on 09 Oct, 2018 04:23 PM

    Steve's Avatar

    Thanks for your feedback. We just sent ourselves an encrypted and signed email with a PDF file attached and ran into no trouble.

    Could you send a test message our way (write to [email blocked]) and make sure the email is structured the same way as the messages you are seeing trouble with.

    Please include a link to this discussion so we know which case the test email is about.

    That way we can try to reproduce the problem.


  4. 4 Posted by Reid Gravelle on 15 Oct, 2018 05:45 PM

    Reid Gravelle's Avatar


    Sorry I haven’t had the time to get back to test. I’ve been quite busy lately. One thing I was wondering, did you create your test message using 2018.3 or 2018.4? All of my messages were signed, not encrypted, had a PDF inline, had an image inline, and were created with 2018.3 installed.

    This issue isn’t going to be a problem for me as I’m going to uninstall the suite because iI’ll have to pay for it. I only use it to sign emails and nobody I know actually bothers with signing or encrypting their own mail. Even after a couple of people noticed that my mail was signed and I told them why they had no interest in signing or encrypting theirs.

    Thanks for your efforts in trying to fix this bug. I would have forwarded an email that was having problems for me but the email address was blocked.


  5. Support Staff 5 Posted by Steve on 16 Oct, 2018 09:20 AM

    Steve's Avatar

    Hey Reid,

    blocked in which way? You tried forwaring the msg to [email blocked]? Which error did you see? Could you send us a screenshot?

    And since additional fixes have been done, could you retry using GPG Suite 2338n from

  6. 6 Posted by Reid Gravelle on 16 Oct, 2018 11:50 AM

    Reid Gravelle's Avatar

    Hi Steve,

    Sorry about not being clear. I thought that you could see the email trail that had the email blocked in the text but you are probably using an app which wouldn’t reflect changes that it made when sending the message out.


  7. Support Staff 7 Posted by Steve on 16 Oct, 2018 08:24 PM

    Steve's Avatar

    I was replying on our support platform. Your discussion is here:

    Sorry in that case. The email is team AT gpgtools DOT org in case the problem persists with 2338n nightly build.

  8. 8 Posted by Reid Gravelle on 17 Oct, 2018 02:33 PM

    Reid Gravelle's Avatar

    Hi Steve,

    I just tried the 2018/10/10 nightly build and the same problem exists. I sent a sample message to the given address. It’s the first time I actually sent something encrypted so I hope that it worked. If not I’ll send it unencrypted. I did find out that the problem lies with attaching images and not PDFs. It happens if I have a message with just an image and no other attachments. It also happens if I write a message with the latest nightly build installed.


  9. Support Staff 9 Posted by Steve on 17 Oct, 2018 05:40 PM

    Steve's Avatar

    The email arrived just fine. PDF + image both open and loaded fine (see screenshot)

    Could you please attach a screenshot of what you are seeing?

  10. 10 Posted by Reid Gravelle on 17 Oct, 2018 06:13 PM

    Reid Gravelle's Avatar

    Hi Steve,

    Here is how the messages appear on my computer. Anyway for me it won’t be a problem as I’m going to be uninstalling the Suite as it’s going to a paid version. I’ve tried to get the people I communicate with to care more about their privacy but failed so I’m the only one that even signs mail. It’s just not worth paying for the app for me.

    If I can help you by running more test I’d be glad to do so.

    Thanks for all of your help,

  11. Support Staff 11 Posted by Steve on 17 Oct, 2018 06:17 PM

    Steve's Avatar

    Please export the message in question, so that we can have a closer look. To export, simply select the message in and press CMD + SHIFT + S, select "Raw Message Source" as type and save it.

    Attach the resulting .eml file to this discussion by visiting it in your browser (email reply should work but sometimes attachments do not arrive).

    Sidenote: we saw you are on macOS 10.12 and the Support Plan only applies to macOS 10.13 and 10.14 so you can use it without purchasing a plan for the time you stay on macOS 10.12.

  12. Steve closed this discussion on 03 Jun, 2019 08:18 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac