GPGServices: Decryption Failed Code = 38

Michelle's Avatar


18 Aug, 2018 05:16 AM

Hello. I have been using GPG Suite seamlessly for 2 years. Since I updated to the newest version, I continue to receive this error. It only happens when I attempt to decrypt a file that I encrypted. If I attempt to decrypt a file that someone else encrypted, it works perfectly fine. I have fixed it temporarily by uninstalling GPG Suite and then reinstalling but it only works on the day I do that. Once I re-open GPG Keychain, it happens every single time. Is there a fix for this?

  1. Support Staff 1 Posted by Steve on 18 Aug, 2018 09:38 AM

    Steve's Avatar

    Hi Michelle,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you please send a debug log from your affected machine: Open System Preferences > GPG Suite > Send Report. Check the box to "attach debug log". Since you already described your issue in this discussion, you don't need to add a lot of detail, but please do add the link to your existing discussion, so I can then merge your debug info with this existing discussion.

    Let's test gpg encryption and decryption in the terminal.

    1. click spotlight at the top right menubar and type 'terminal'
    2. open by pressing enter
    3. in the new terminal window
    4. paste the following without the ' 'gpg2 -ae --default-recipient-self <<<OK'
    5. a PGP message will be created
    6. paste the following without the ' 'gpg2 -ae --default-recipient-self <<<OK | gpg2 -d'
    7. you will be asked for your password (if your password is still in the cache or stored in macOS keychain you will not be asked)
    8. when everything is fine you should see the word "OK" in your terminal - in that case decryption worked as expected

    All the best,

  2. 2 Posted by Michelle on 18 Aug, 2018 06:57 PM

    Michelle's Avatar

    Of course, after a week of this problem happening it somehow stopped happening after I posted this. It seems to be working ok for the moment. If it starts again, I will send a debug log. Thanks!

  3. Support Staff 3 Posted by Steve on 20 Aug, 2018 09:45 AM

    Steve's Avatar

    Sounds good. Just keep a close eye on this.

    I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  4. Steve closed this discussion on 20 Aug, 2018 09:45 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac