GPG Keychain: GPGServices: Pinentry Mac keeps asking for passphrase

scott jones's Avatar

scott jones

25 Jul, 2018 12:36 AM

hi there

i have same issue reported in here >> https://gpgtools.tenderapp.com/discussions/problems/58498-gpgservic......

but I don't have ignore-cache-for-signing line in my gpg-agent.conf file to remove like what solved the same problem for user here, any ideas?

Expected
not asking for my pass phrase every single time I send email

macOS                   10.12.6     16G1510
GPG Suite               2018.3      2223    (8d0c266)
GPGMail                 2.7.3       1268    (b7a4d043)
GPG Keychain            1.4.4       1460    (9010342)
GPGServices             1.11.4      1013    (0b04f6c)
MacGPG                  2.2.8       916     (0ed4a99)
GPG Suite Preferences   2.1.2       997     (1a09bc7)
Libmacgpg               0.8.5       863     (0707962)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 25 Jul, 2018 03:54 PM

    Steve's Avatar

    Hi Scott,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Please see this KB-article on how to manage passwords for your keys.

    Do you have the option to store your password in macOS keychain enabled?

    When pinentry shows up, do you see the corresponding checkbox ticked?

    When you send yourself a test message which is encrypted and signed and enter your password with the checkbox enabled and then send another test email, are you then still asked for your password?

    Best,
    steve

  2. 2 Posted by Scott Jones on 25 Jul, 2018 04:18 PM

    Scott Jones's Avatar

    Greetings,

    Thanks so much for your support!

    Do you have the option to store your password in macOS keychain enabled?
    *Yes I have that box checked (it has been, no changes recently, this
    just started happening)

    When pinentry shows up, do you see the corresponding checkbox ticked?
    *Yes and it is checked by default on that pop up window, which is why
    I find it odd keeps popping up

    When you send yourself a test message which is encrypted and signed
    and enter your password with the checkbox enabled and then send
    another test email, are you then still asked for your password?
    *I just sent test message, it did not prompt me for password. Maybe
    the behavior I"m seeing is random / not every time.

    I rebooted couple of times since this trouble, and checks for updates
    on GPG suite (says current = 2018.3)

    Next time it pops up I'll catch screen shot of it and share!

    Cheers,

    Scott

  3. Support Staff 3 Posted by Steve on 26 Jul, 2018 10:50 AM

    Steve's Avatar

    Thanks for the detailed reply.

    This sounds odd indeed. Note that the transition from MacGPG 2.0.x to 2.2.x requires users to re-enter their password for their OpenPGP key. And depending on the key, you may be asked twice (once for signing, once for decrypting). So far the requests would be expected.

    The fact that things are now working as expected is good news.

    Please do as you already wrote: closely observe the behavior and let us know if you are asked again and in that case please create a screenshot of the request.

    Best,
    steve

  4. 4 Posted by Scott Jones on 26 Jul, 2018 03:38 PM

    Scott Jones's Avatar

    Greetings Steve,

    Thanks again for the great support!

    For more testing, I un-checked to cache, then re-checked to cache
    (Perhaps to toggle the process responsible or caching this OFF then
    back ON). Rebooted, and so far I have not been repeatedly promoted
    for password today.

    Going to work throughout the day (lots of email) and let you know how it goes!!

    Cheers,

    Scott

  5. Support Staff 5 Posted by Steve on 29 Jul, 2018 11:13 AM

    Steve's Avatar

    Hey Scott,

    that sounds like good news. Is your setup now working as expected?

    Best,
    steve

  6. 6 Posted by Scott Jones on 30 Jul, 2018 01:41 AM

    Scott Jones's Avatar

    Hi Steve,

    So far no more pop up, but I've been on PTO, going to send lots of
    email tomorrow will let you know!

    Thanks!

    Scott

  7. Steve closed this discussion on 17 Nov, 2018 06:29 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac