Inst prob on Leopard/PPC

Wolf's Avatar

Wolf

28 Jan, 2012 07:56 PM

Hello,

thanks for making MacGPG so highly comfortable - great job! - I started to use GnuPG something like 10 years ago - and now wanted to use it on a PowerBook G4, running Leo 10.5.8.

Installation is easy, everything fine. Importing my keysets works (from ~/.gnupg - took me some time to find the directory). Then launching Apple Mail - and nothing. At Encrypted messages no buttons to decrypt it, no entry in Mail.app preferences, no menu entries. Nothing at all.

The bundle seems to install properly - see attachment.
AFAIK GPGTools is for PowerPC and Leopard as well - true???

Yours, Wolf

  1. Support Staff 1 Posted by Steve on 28 Jan, 2012 08:50 PM

    Steve's Avatar

    Hey Wolf,

    thanks for your kind words. Where did you find that antique version of GPGMail? Did you go to a museum? ;)

    Just kidding, but honestly that version must be more than 1 1/2 years old.

    Would you be so kind and try our latest GPGTools Installer from here: http://www.gpgtools.org/installer/index.html

    If you then encounter any issues or need some help: simply re-open this discussion and we're glad to help.

    Best wishes, steve

  2. Steve closed this discussion on 28 Jan, 2012 08:50 PM.

  3. Wolf re-opened this discussion on 29 Jan, 2012 01:02 AM

  4. 2 Posted by Wolf on 29 Jan, 2012 01:02 AM

    Wolf's Avatar

    Sorry, I may be stupid - but that's exactly what I installed:
    GPGTools-20111224.dmg

    What could have gone wrong? -
    BTW.: I used that mailbundle for years and it didnt work so badly…

    Wolf

  5. 3 Posted by Alex on 29 Jan, 2012 09:06 AM

    Alex's Avatar

    Then launching Apple Mail - and nothing ... I used that mailbundle for years and it didnt work so badly…

    What is the case on your system? Either it is not working or it never worked "so badly" (btw. we've not changed the sources for 10.5 for years). So I assume with "so badly" you mean Mail.app doesn't load the plugin.

    In this case the installer might not have enabled Mail plugins for you (but it should have). Could please open Terminal.app and type the following two lines?

    defaults write com.apple.mail EnableBundles -bool YES 
    defaults write com.apple.mail BundleCompatibilityVersion -int 3
    
  6. 4 Posted by Wolf on 29 Jan, 2012 09:41 AM

    Wolf's Avatar

    Hello,

    thanks for the extremely quick and friendly answer - hardly any commercial company will perform that well.

    Your hint solves my problem - now things are working well.

    Wouldnt it be a good idea to perform that two lines routinely during the installation procedure?

    Yours,
    Wolf

  7. 5 Posted by Alex on 29 Jan, 2012 09:44 AM

    Alex's Avatar

    Hi Wolf, good to hear that. But this is actually what the installer is about: these two lines should be performed. Could you please add the installer log when running the latest installer on your system? (While installing, please click on "Menu: Window > Installer Log" (or press CMD+L), switch to "Show All Logs".)

  8. 6 Posted by Wolf on 29 Jan, 2012 10:56 AM

    Wolf's Avatar

    Thanks for your patience.
    I uninstalled GPGTools first, than reinstalled them. The log is attached.

    Greetings, Wolf

  9. Support Staff 7 Posted by Steve on 30 Jan, 2012 10:19 AM

    Steve's Avatar

    Thanks. We'll have a look at the installation log to see how we can improve the installer. I'm closing this for now. If you have further questions, just open a new discussion any time. :)

    All the best, steve

  10. Steve closed this discussion on 30 Jan, 2012 10:19 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac