GPG Keychain: public servers

Pavel's Avatar

Pavel

05 May, 2018 11:01 AM

Please repeat your search and see if it works then. Should the problem persist, file a support request via System Preferences > GPG Suite > Send Report. Please copy the entire error message into the description field and add the search term you used for your query. We recommend to include the debug log, since that provides additional helpful information to solve your problem.

Details:
Search keys failed! (Server indicated a failure)
Code = 219
Error text:
gpg: error searching keyserver: Server indicated a failure
gpg: keyserver search failed: Server indicated a failure

all anower public server in list so - error searching …

Expected
hkps://hkps.pool.sks-keyservers.net, pep.mit.edu, some.key.server.org, some.key.server.org,

Additional info
send me, pls. working server list, an how I can update this list ?
my installed version is 1.4.2 (1403)

macOS                   10.13.4     17E202
GPG Suite               2018.1      2083    (9658b70)
GPGMail                 3.0b4       1272    (461cda15)
GPG Keychain            1.4.2       1403    (128637e)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       900     (cead4f9)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.2       829     (943132e)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 06 May, 2018 12:13 PM

    Steve's Avatar

    Hi Pavel,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you please download and install our latest hotfix GPG Suite and see if that solves your problem.

    In case the issue persists: This problem can have various causes.

    Please open Terminal.app, paste the following command and post the output into this discussion.

    nslookup hkps.pool.sks-keyservers.net
    

    Then execute the following command:

     echo "debug-level guru" >> ~/.gnupg/dirmngr.conf
     echo "debug-all" >> ~/.gnupg/dirmngr.conf
     echo "log-file /tmp/dirmngr.log" >> ~/.gnupg/dirmngr.conf
     killall dirmngr
     gpg --keyserver hkps://hkps.pool.sks-keyservers.net --search-keys [email blocked]
    

    After running these commands, please send us the /tmp/dirmngr.log file

    1. open finder and press ⇧⌘G
    2. paste /tmp/dirmngr.log
    

    Once you are done, let's remove the debugging option:

    1. open finder and press ⇧⌘G
    2. paste ~/.gnupg/dirmngr.conf
    3. open that file with TextEdit
    4. remove the following lines
        * debug-level guru
        * debug-all
        * log-file /tmp/dirmngr.log
    

    Now open Terminal.app again and execute the following commands:

    rm /tmp/dirmngr.log
    killall dirmngr
    

    Another question: Are you using Little Snitch or any other firewall-like software on your mac? If so, please temporarily disable that software and repeat the process. Can you then connect to the key servers as expected?

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. Support Staff 2 Posted by Steve on 18 Jul, 2018 02:41 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  3. Steve closed this discussion on 18 Jul, 2018 02:41 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac