GPGMail: S/MIME default not working

Roman's Avatar

Roman

22 Mar, 2018 04:12 PM

defaults write org.gpgtools.gpgmail DefaultSecurityMethod -int 2
defaults read org.gpgtools.gpgmail
{
    DefaultSecurityMethod = 2;
    OptionallyEncryptDrafts = 0;
    SignNewEmailsByDefault = 0;
}

Reboot

Result: Any new mail or reply defaults to GPG
Expected: New mail starts in S/MIME mode

  1. Support Staff 1 Posted by Steve on 22 Mar, 2018 04:26 PM

    Steve's Avatar

    Hi Roman,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you temporarily disable GPGMail:

    • shut down mail.app
    • open finder
    • navigate to /Library/Mail/Bundles or ~/Library/Mail/Bundles and copy GPGMail.mailbundle to your desktop
    • now delete GPGMail.mailbundle from the original folder

    Restart mail and check in Mail.app > Preferences if you still see GPGMail. It should be gone.

    To re-enable mail, close Mail.app and move the bundle file back to the Bundles folder.

    Does S/MIME work as expected then?

    If not, you may need to delete and re-import the S/MIME cert.

    Then re-enabled GPGMail and see if the default is working.

    Best,
    steve

  2. Support Staff 2 Posted by Steve on 08 Jul, 2018 12:07 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  3. Steve closed this discussion on 08 Jul, 2018 12:07 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac