GPGMail: Problem decrypting PGP Inline

Alex's Avatar

Alex

13 Feb, 2018 08:25 PM

I just upgraded to the latest beta release for High Sierra, and now certain PGP Inline messages are no longer being decrypted. The ones I’ve noticed were all encrypted with gpg4o, at least some of which were sent using v5.3.8.9035 of gpg4o. Before the update, these messages decrypted properly (and I can decrypt them manually or with another mail client, like MailMate).

Expected
I expected the PGP Inline messages to decrypt properly.

macOS                   10.13.2     17C88
GPG Suite               2018.1      2083    (9658b70)
GPGMail                 3.0b4       1272    (461cda15)
GPG Keychain            1.4.2       1403    (128637e)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       900     (cead4f9)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.2       829     (943132e)
pinentry                0.9.7.1     9       (db18340)
  1. Support Staff 1 Posted by Steve on 14 Feb, 2018 04:47 PM

    Steve's Avatar

    Hi Alex,

    the changes for GPGMail for the 2018.1 release have not been that big. Could you double check you are still able to decrypt the messages from gpg4o after installing GPG Suite 2017.3?

    You may then update again to 2018.1.

    Can you share one of those problematic messages with us? Please export the message in question, so that we can have a closer look. To export, simply select the message in Mail.app and press CMD + SHIFT + S, select "Raw Message Source" as type and save it.

    Attach the resulting .eml file to this discussion by visiting it in your browser (email reply should work but sometimes attachments do not arrive).

    Best,
    steve

  2. Support Staff 2 Posted by Steve on 14 Feb, 2018 04:47 PM

    Steve's Avatar

    PS: To benefit from the latest security fixes from apple, you may want to check for pending macOS updates in the MacAppStore. General info about Apple security releases including the latest macOS release.

  3. 3 Posted by Tobias on 23 Feb, 2018 10:46 AM

    Tobias's Avatar

    Hi Steve,
    I am part of the gpg4o team and just saw this post.
    If it is any help you might want to exchange test emails for compatibility tests.
    For this purpose we provide the mail address "openpgp . test @ giepa . de" (please remove the blanks) where you can send us signed and encrypted mails. The public key can be found on common keyservers with the ID 0x9B05894174DEBFA4

    Please note that there is no robot behind it – every mail is handled by humans. So please do not abuse it.
    If you can send us your public key we will test the other way around happily.

    Tobias

  4. Support Staff 4 Posted by Steve on 23 Feb, 2018 12:13 PM

    Steve's Avatar

    Thanks for the offer. We sent a message requesting an inline test reply.

  5. 5 Posted by Alex Abdo on 23 Feb, 2018 12:20 PM

    Alex Abdo's Avatar

    Steve and Tobias,

    Sorry for being slow to send a test. I’ll try to get to it later today.

    Alex

  6. Support Staff 6 Posted by Steve on 23 Feb, 2018 12:21 PM

    Steve's Avatar

    Not necessary. We were able to reproduce the issue and will create a ticket soon.

  7. 7 Posted by Alex Abdo on 23 Feb, 2018 12:23 PM

    Alex Abdo's Avatar

    Great. Thanks so much.

  8. Support Staff 8 Posted by Steve on 20 Mar, 2018 10:37 AM

    Steve's Avatar

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussions should you run into further problems or need assistance.

  9. Support Staff 9 Posted by Steve on 20 Mar, 2018 10:38 AM

    Steve's Avatar

    There is a simple workaround for the time we are waiting for a fix. Drag the message in question to your desktop and double click the created file. The message will then decrypt as expected.

  10. Support Staff 10 Posted by Steve on 26 Mar, 2018 05:59 PM

    Steve's Avatar

    Hi Alex, (and cc: Tobias)

    good news: we think we fixed this issue.

    Could you please download and install our latest hotfix GPG Suite and see if that solves your problem.

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  11. 11 Posted by Alex Abdo on 27 Mar, 2018 03:32 PM

    Alex Abdo's Avatar

    Thanks so much, Steve, that worked!

  12. Support Staff 12 Posted by Steve on 27 Mar, 2018 04:39 PM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    steve

  13. Steve closed this discussion on 27 Mar, 2018 04:39 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac