MacGPG: Passphrase not accepted since update

Philip Brewer's Avatar

Philip Brewer

21 Dec, 2017 03:12 PM

Since I updated GPGMail, I've been unable to read or send encrypted mail. I get prompted for my passphrase, but just get reprompted after I type it.

Expected
To see a decrypted message.

Additional info
I have verified that I can still decrypt files from the command line.

macOS                   10.13.2     17C88
GPG Suite               2017.2      2063    (e459897)
GPGMail                 3.0b2       1268    (3353e50)
GPG Keychain            1.4.1       1391    (b5c89a4)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       895     (17e3e67)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.1       826     (9410d73)
pinentry                0.9.7       6       (6aeb033)
  1. 1 Posted by Jashan Chittesh on 22 Dec, 2017 10:27 AM

    Jashan Chittesh's Avatar

    I just wanted to confirm that I'm seeing the same issue. I can still sign messages with all my private keys - in that case, I am asked my passphrase once, then the message is signed, all is well. However, when trying to decrypt any message, to any of my public keys, I always get that same behavior: I'm asked for the passphrase three times, then it fails ("Decryption failed with unknown error!" but details tell me it's the passphrase).

    This also happens for some reason when trying to store a draft in Apple Mail.

    I have also tried encrypting / signing / decrypting with files, using Services / OpenPGP / Encrypt, Decrypt, Sign File. This gives me the exact same results (signing works, decrypting does not work).

    Decrypting via command line works without any issues.

  2. Support Staff 2 Posted by Luke Le on 22 Dec, 2017 10:39 AM

    Luke Le's Avatar

    Hi Jashan,

    due to an error in our latest stable release, a custom version of GnuPG was preferred over our own, which lead to the problems described by you. From the debug log I can tell, that you have an old GnuPG 1.x version installed, which is accidentally picked up and used by GPG Suite.
    Our latest release, GPG Suite 2017.3 addresses this issue.

    Please find it on https://gpgtools.org

    Hope this helps.

  3. 3 Posted by Philip Brewer on 22 Dec, 2017 02:10 PM

    Philip Brewer's Avatar

    That fixed it for me.

  4. Support Staff 4 Posted by Steve on 22 Dec, 2017 10:00 PM

    Steve's Avatar

    @Jashan: Are you back to working state as well after updating to the 2017.3 release?

  5. Support Staff 5 Posted by Steve on 26 Mar, 2018 05:03 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  6. Steve closed this discussion on 26 Mar, 2018 05:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac