Error with Mail when updated GPGSuite

Gab's Avatar


13 Dec, 2017 02:51 PM

Which of our tools is giving you problems?

I'm using GPG Suite with Mail .

Attach a screenshot of the version info for all installed components (how to:

Describe your problem. Add as much detail as possible.

I'm getting this error when I try to send an encrypted mail:

gpg(49419,0x7fffc02583c0) malloc: *** error for object 0x7fb02ac088d0: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug

What did you expect instead

The mail to be sent

Describe steps leading to the problem.

I updated GPGSuite

Are you using any other plugins?


  1. Support Staff 1 Posted by Luke Le on 13 Dec, 2017 04:01 PM

    Luke Le's Avatar

    Hi Gab,

    we are very sorry to hear you are experiencing problems with the latest version of GPG Suite.
    We believe this problem is triggered if a user has a custom GnuPG version installed along side of our MacGPG. From the debug log I can tell that that is the case for you.

    Could you please download and install our latest GPG Suite nightly build and see if it solves your problem. That page also has sig and SHA256 to verify the download.

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by gaba on 13 Dec, 2017 04:18 PM

    gaba's Avatar

    Yes. That worked. I’m using the dev version now. Thanks

  3. Support Staff 3 Posted by Steve on 13 Dec, 2017 07:14 PM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  4. Steve closed this discussion on 13 Dec, 2017 07:14 PM.

  5. Steve closed this discussion on 14 Dec, 2017 05:06 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac