GPG Keychain: Retrieve Key Failure

Tom Fleischmn's Avatar

Tom Fleischmn

12 Dec, 2017 02:55 AM

Receive keys failed!
Code = 0
Error text:
gpg: requesting key C2ACF4DD from hkps server
gpg: no handler for keyserver scheme `hkps'
gpg: keyserver receive failed: keyserver error

Expected to retrieve key

macOS                   10.11.6     15G1702
GPG Suite               2017.2      2063    (e459897)
GPGMail                 2.6.4       1249    (d765eca)
GPG Keychain            1.4.1       1391    (b5c89a4)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       895     (17e3e67)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.1       826     (9410d73)
pinentry                0.9.7       6       (6aeb033)
  1. Support Staff 1 Posted by Luke Le on 13 Dec, 2017 03:01 PM

    Luke Le's Avatar

    Hi Tom,

    we are very sorry to hear you are experiencing problems with the latest version of GPG Suite.
    We believe this problem is triggered if a user has a custom GnuPG version installed along side of our MacGPG. From the debug log I can tell that that is the case for you.

    Could you please download and install our latest GPG Suite nightly build and see if it solves your problem. That page also has sig and SHA256 to verify the download.
    Please log out and back in after installing the nightly.

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Tom Fleischman on 13 Dec, 2017 03:47 PM

    Tom Fleischman's Avatar

    Hello Luke -

    Thank you very much! This has fixed the problem and the keyserver tools are now working.

    I should also let you know that the reason I wanted to retrieve my key from the keyserver was that after installing GPG Suite 2017.2 2063 I was unable to decrypt previously encrypted text. GPG Suite 2017.2 was rejecting my passphrase giving the message “Bad passphrase Code=11". Installing this nightly (2068n) has solved both problems. I can now connect to the keyserver and I am able to decrypt previously encrypted text. I tried reinstalling 2063 and the problems reappeared, and then after reinstalling 2068n the problems were again resolved. I will now skip version 2063.

    Thanks again for your help.



  3. Support Staff 3 Posted by Luke Le on 13 Dec, 2017 03:51 PM

    Luke Le's Avatar

    Hi Tom,

    yes, our current stable version has a problem where in some very few cases, keyserver lookup doesn't work. The passphrase issue is related to the custom GnuPG installation (which is very likely pretty old) being preferred over our own GnuPG version.

    Very happy that everything is working again now!

    Closing this discussion. Feel free to open a new one anytime should you have questions or run into problems.

  4. Luke Le closed this discussion on 13 Dec, 2017 03:51 PM.

  5. Steve closed this discussion on 14 Dec, 2017 05:04 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac