GPGMail: Inappropriate ioctl for device, please use 'hkp-cacert' in dirmngr.conf = since last release

Arkadiusz's Avatar

Arkadiusz

11 Dec, 2017 12:51 PM

When I'm trying to send email with loaded gpgmail I'm receiving error showed below.

It's happening since last beta update

Expected
GPG error message:
gpg: keyserver option 'ca-cert-file' is obsolete; please use 'hkp-cacert' in dirmngr.conf
gpg: zaszyfrowano 2048-bitowym kluczem RSA o identyfikatorze 0x08D3BB8060C94BC7, stworzonym 2017-11-07
"[email blocked]'' gpg: error with decrypting with public key: Inappropriate ioctl for device
gpg: decryption error: No secret key

Please contact us, including the GPG error message, at https://gpgtools.tenderapp.com/

Additional info
I have this public key, it's visible and usable in GPG Keychain

macOS                   10.13.2     17C85a
GPG Suite               2017.2      2063    (e459897)
GPGMail                 3.0b2       1268    (3353e50)
GPG Keychain            1.4.1       1391    (b5c89a4)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       895     (17e3e67)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.1       826     (9410d73)
pinentry                0.9.7       6       (6aeb033)
  1. 1 Posted by Stanislas Lejay on 11 Dec, 2017 01:01 PM

    Stanislas Lejay's Avatar

    Hi, I was about to start a discussion about the same issue

    Unfortunately we can't handle the error at this point.
    
    Should your problem persist, please contact us at https://gpgtools.tenderapp.com/ with the following error description:
    
    gpg: signing failed: Inappropriate ioctl for device
    gpg: signing failed: Inappropriate ioctl for device
    
  2. Support Staff 2 Posted by Luke Le on 13 Dec, 2017 02:30 PM

    Luke Le's Avatar

    Hi Arkadiusz, Stanislas,

    we are very sorry to hear you are experiencing problems with the latest version of GPG Suite.
    We believe this problem is triggered if a user has a custom GnuPG version installed along side of our MacGPG. From the debug log I can tell that that is the case for you.

    Could you please download and install our latest GPG Suite nightly build and see if it solves your problem. That page also has sig and SHA256 to verify the download.
    https://releases.gpgtools.org/nightlies/

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  3. 3 Posted by Arkadiusz on 13 Dec, 2017 02:34 PM

    Arkadiusz's Avatar

    Hey Luke

    I solved this problem 2 hours ago. I thing you're right but what is strange - it works before.

    What I did to fix this problem?
    - Backed up whole gpg keyring - Removed .gnupg directory and created it again - Imported this keyring again - Installed pinentry - This solved my "ioctl" problem totally.

    Thank you, maybe it will be helpful

  4. Support Staff 4 Posted by Luke Le on 13 Dec, 2017 02:47 PM

    Luke Le's Avatar

    Hi Arkadiusz,

    it is certainly possible to fix this problem differently, since basically it means that there's a problem with your custom installation of gnupg. GPG Suite should work with a custom gnupg version, but we can't guarantee that. What the new version fixes is that it always prefers our own gnupg version over a custom one.

    Thanks for the update.

  5. Steve closed this discussion on 14 Dec, 2017 05:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac