GPG Suite Preferences: GPG Suite does not respect default key

roland's Avatar

roland

10 Dec, 2017 11:24 AM

It looks like GPG Suite does not respect the default key.
Steps to reproduce:
1. Open system preferences - gpg suite
2. Use the drop down menu to select my new default key.
3. Exit system preferences
4. When re-opening system preferences - gpg suite it again shows my old key.

Expected
I expect GPG Suite to save my default key setting, when I exit system preferences.

macOS                   10.13.1     17B1003
GPG Suite               2017.2      2063    (e459897)
GPGMail                 3.0b2       1268    (3353e50)
GPG Keychain            1.4.1       1391    (b5c89a4)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       895     (17e3e67)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.1       826     (9410d73)
pinentry                0.9.7       6       (6aeb033)
  1. Support Staff 1 Posted by Steve on 10 Dec, 2017 04:21 PM

    Steve's Avatar

    Hey Roland,

    welcome to the GPGTools community support platform. Sorry you are having problems using GPG Suite.

    The symptoms you are describing may indicate that you are using gpg 1.x. in parallel to 2.2.x which is the version installed by GPG Suite. Please install the latest GPG Suite nightly build. That build has a fix to favor our gpg version.

    Then check if your problem persists.

    All the best,
    steve

  2. 2 Posted by Roland Spitzlin... on 11 Dec, 2017 04:01 PM

    Roland Spitzlinger's Avatar

    Hi Steve,

    thanx for the hint but unfortunately it did not solve the problem.
    PGP Suite is still not respecting my default key.

    Best wishes,
    Roland

  3. Support Staff 3 Posted by Luke Le on 14 Dec, 2017 12:38 PM

    Luke Le's Avatar

    Hi Roland,

    könntest du bitte folgendes versuchen.

    1.) Öffne den Terminal und führ folgenden Befehl aus:

    cat ~/.gnupg/gpg.conf | grep default-key
    

    2.) Öffnen Systemeinstellungen -> GPG Suite und wähle deinen neuen Key aus
    3.) Schließe Systemeinstellungen

    2.) Führ erneut den Befehl von Punkt 1 aus

    Bitte poste den Output beider Befehle.

    Danke!

  4. 4 Posted by Roland Spitzlin... on 14 Dec, 2017 02:56 PM

    Roland Spitzlinger's Avatar

    Alles klar.
    Hier die Ergebnisse der beiden Terminalbefehle (kein Unterschied)

    Last login: Mon Dec 11 10:42:58 on ttys001
    Roland-Air:~ Rol$ cat ~/.gnupg/gpg.conf | grep default-key
    #default-key 621CC013
    Roland-Air:~ Rol$
    Roland-Air:~ Rol$ cat ~/.gnupg/gpg.conf | grep default-key
    #default-key 621CC013
    Roland-Air:~ Rol$ cat ~/.gnupg/gpg.conf | grep default-key
    #default-key 621CC013
    Roland-Air:~ Rol$

    Unter Systemeinstellungen kann ich den Standardschlüssel weiterhin nicht speichern.

    LG Roland

  5. Support Staff 5 Posted by Luke Le on 14 Dec, 2017 02:58 PM

    Luke Le's Avatar

    Vielen Dank, ich glaub das hilft uns weiter.
    Es wirkt so, als würde es nicht klappen einen default-key zu setzen, wenn nicht bereits einer gesetzt ist.

    Wir werden das genauer untersuchen und dir dann Bescheid geben.

    Wenn du den default-key in deiner ~/.gnupg/gpg.conf selbst setzt, sollte es danach möglich sein den von GPG Suite Preferences aus zu verändern (sollte meine Vermutung zutreffen).

  6. Support Staff 6 Posted by Steve on 26 Mar, 2018 03:58 PM

    Steve's Avatar

    Hi Roland,

    konntest du das Problem bzgl. deinem Default key lösen mittlerweile oder besteht es mit der aktuellen Version von GPG Suite fort?

    Viele Grüße,
    steve

  7. 7 Posted by Roland Spitzlin... on 26 Mar, 2018 09:27 PM

    Roland Spitzlinger's Avatar

    Hi Steve,

    ja, das Problem besteht leider immer noch.
    Siehe auch meinen Emailverkehr mit Luke vom 22. und 23. März.

    LG Roland

  8. Support Staff 8 Posted by Steve on 26 Mar, 2018 09:36 PM

    Steve's Avatar

    Verstehe. Du hast eine neue Diskussion eröffnet. Die ist hier:
    https://gpgtools.tenderapp.com/discussions/problems/69696-gpg-keych...

    Dann machen wir dort weiter. Ich schließe diese alte Diskussion um Konfusionen zu vermeiden. Wir melden uns die Tage bei dir in der neuen Diskussion.

    Schönen Abend dir noch,
    steve

  9. Steve closed this discussion on 26 Mar, 2018 09:36 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac