GPGMail: Can't decrypt - Won't accept passphrase

Geoff's Avatar

Geoff

09 Dec, 2017 06:39 PM

Updated to latest. GPGMail 3.0b2. I can sign mail, but not decrypt. It won’t accept my passphrase.

Expected
I kinda expected this basic operation to work.

macOS                   10.13.2     17C88
GPG Suite               2017.2      2063    (e459897)
GPGMail                 3.0b2       1268    (3353e50)
GPG Keychain            1.4.1       1391    (b5c89a4)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       895     (17e3e67)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.1       826     (9410d73)
pinentry                0.9.7       6       (6aeb033)
  1. Support Staff 1 Posted by Luke Le on 09 Dec, 2017 07:00 PM

    Luke Le's Avatar

    Hi Geoff,

    we are very sorry to hear you are experiencing problems with the latest version of GPG Suite.
    We believe this problem is triggered if a user has a custom GnuPG version installed along side of our MacGPG. From the debug log I can tell that that is the case for you.

    Could you please download and install our latest GPG Suite nightly build and see if it solves your problem. That page also has sig and SHA256 to verify the download.
    https://releases.gpgtools.org/nightlies/

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Michael on 14 Dec, 2017 08:39 AM

    Michael's Avatar

    I had the same Problem as Geoff with Version GPGMail 3.0b2. The nightly build from 2017-12-09 fixed that problem for me. Thats for the Info Luke Le.

    Kind regards,
    Michael

  3. Support Staff 3 Posted by Steve on 14 Dec, 2017 10:24 AM

    Steve's Avatar

    Michael, thanks for the feedback.

  4. 4 Posted by Geoff on 14 Dec, 2017 12:01 PM

    Geoff's Avatar

    Removing the older custom GnuPG also solved the problem

  5. Support Staff 5 Posted by Luke Le on 14 Dec, 2017 12:03 PM

    Luke Le's Avatar

    Hi Geoff,

    yes that should help as well. Future versions of GPG Suite will always prefer our own MacGPG version. Glad this issue is solved for you as well.

    Closing this discussion. Feel free to open a new one anytime should you have questions or run into problems.

  6. Luke Le closed this discussion on 14 Dec, 2017 12:03 PM.

  7. Steve closed this discussion on 14 Dec, 2017 04:57 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac