GPGMail: Mail crashes after trying to sign or encrypt a mail

mbroenner's Avatar

mbroenner

08 Dec, 2017 08:02 AM

When I sign or encrypt a mail I get asked to insert my key but the key is not accepted. After a couple of unsuccessful retries I try to cancel the signation/encryption and when trying to send the mail than without, mail crashes.

Expected
Not asking for my key.
Accepting the correct key.
Not crashing when sending without signature/encryption.

macOS                   10.13.2     17C88
GPG Suite               2017.2      2063    (e459897)
GPGMail                 3.0b2       1268    (3353e50)
GPG Keychain            1.4.1       1391    (b5c89a4)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       895     (17e3e67)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.1       826     (9410d73)
pinentry                0.9.7       6       (6aeb033)
  1. Support Staff 1 Posted by Luke Le on 08 Dec, 2017 06:36 PM

    Luke Le's Avatar

    Hi M,

    we are very sorry to hear you are experiencing problems with the latest version of GPG Suite.
    We believe this problem is triggered if a user has a custom GnuPG version installed along side of our MacGPG.

    Could you please download and install our latest GPG Suite nightly build and see if it solves your problem. That page also has sig and SHA256 to verify the download.

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by mbroenner on 08 Dec, 2017 10:37 PM

    mbroenner's Avatar

    Hi, I tried a complete new download but the result was the same.
    I went back to the last version.
    --
    Matthias Brönner

  3. Support Staff 3 Posted by Luke Le on 08 Dec, 2017 10:37 PM

    Luke Le's Avatar

    That is very curious. Do you have a crashlog by any chance?

  4. 4 Posted by mbroenner on 08 Dec, 2017 10:40 PM

    mbroenner's Avatar

    Well, I thought that - when I created the report - it asked me to attach one and I did.
    But I can send another one if you tell me where/how to find.
    --
    Matthias Brönner

  5. Support Staff 5 Posted by Luke Le on 08 Dec, 2017 10:42 PM

    Luke Le's Avatar

    Ah sorry, no, that's a debug log, which contains some information in regards to your gnupg and mail setup. The Mail crash log is specifically created by Mail itself.

    You should be able to find it in your user's Library folder under:
    ~/Library/Logs/DiagnosticReports/

    Thanks!

  6. 6 Posted by mbroenner on 09 Dec, 2017 06:13 AM

    mbroenner's Avatar

    Okay, here we are - I can send you an bunch of that.
    --
    Matthias Brönner

  7. Support Staff 7 Posted by Luke Le on 09 Dec, 2017 08:17 AM

    Luke Le's Avatar

    Hi Matthias,

    thank you very much. I believe this might be a incompatibility with Mail-Act-On.
    Would it be possible to uninstall/disable Mail-Act-On temporarily to see if GPGMail works reliably after that?

    Thanks!

  8. 8 Posted by mbroenner on 09 Dec, 2017 08:30 AM

    mbroenner's Avatar

    Ah!
    If you can qualify that hint a little bit, I would forward this to the MailTags guys.
    BTW … its a really cool tool - do you know it?

    Well, as I told you I installed the former GPGMail version. Maybe I try it …. but must look when …
    m.
    --
    Matthias Brönner

  9. 9 Posted by mbroenner on 09 Dec, 2017 08:48 AM

    mbroenner's Avatar

    Okay, I did it.
    Same result.
    Crashlog attached.
    There is still another Plugin - MailActOn (but I don’t want to remove this too)
    --
    Matthias Brönner

  10. Support Staff 10 Posted by Luke Le on 09 Dec, 2017 05:03 PM

    Luke Le's Avatar

    Hi Matthias,

    thanks for the update. We will talk to the folks at Small Cubed and will let you know, once we know more.

    Thanks for testing in the meantime.

  11. Support Staff 11 Posted by Luke Le on 09 Dec, 2017 05:04 PM

    Luke Le's Avatar

    Ah, one question, since I didn't really understand it. Did you try the nightly?

  12. 12 Posted by mbroenner on 09 Dec, 2017 09:10 PM

    mbroenner's Avatar

    .. the nightly built?
    Probably not - I took the one promoted on the home page.
    --
    Matthias Brönner

  13. Support Staff 13 Posted by Luke Le on 09 Dec, 2017 09:14 PM

    Luke Le's Avatar

    Ah ok, because that one was supposed to fix your original issue.
    From your debug log it's clear that you have an old custom version of GnuPG installed, which the 2017.2 release has a problem with. The nightly build fixes that problem, and includes all the GPGMail changes for 2017.2

  14. Support Staff 14 Posted by Steve on 09 Dec, 2017 10:14 PM

    Steve's Avatar

    The nightly link is buried somewhat down this discussion in comment 1.

    Or here:
    https://releases.gpgtools.org/nightlies/

  15. Support Staff 15 Posted by Steve on 26 Mar, 2018 02:10 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  16. Steve closed this discussion on 26 Mar, 2018 02:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac