GPGMail: pinentry keeps asking for passwords (removing old gpg 1 solved the problem)

Alexander Presber's Avatar

Alexander Presber

07 Dec, 2017 09:08 AM

Since I installed the Update to GPG Suite 2017.2 this morning, Mail (Version 9.3 (3124)) on MacOSX (Version 10.11.6 (15G17023)) keeps asking me for the passwords to unlock my secret keys in a window called "Pinentry Mac".
It always does so three times in a row for each of my mail accounts.
In the end it does not decrypt any mails (e.g. my draft mails) anymore.

GPGMail should decrypt the mails.
Also it should store my passwords in the keychain (like determined in the settings - and like it used to do).

Additional info
I restarted Mail and my computer, I also un-installed and re-installed GPGSuite, to no avail.

macOS                   10.11.6     15G1702
GPG Suite               2017.2      2063    (e459897)
GPGMail                 2.6.4       1249    (d765eca)
GPG Keychain            1.4.1       1391    (b5c89a4)
GPGServices             1.11.2      969     (e5438f7)
MacGPG                  2.2.3       895     (17e3e67)
GPG Suite Preferences   2.1.1       993     (05eb1a6)
Libmacgpg               0.8.1       826     (9410d73)
pinentry                0.9.7       6       (6aeb033)
  1. Support Staff 1 Posted by Luke Le on 07 Dec, 2017 02:13 PM

    Luke Le's Avatar

    Hi Alexander,

    we are very sorry to hear that you are experiencing troubles with our latest version of GPG Suite.

    Your debug log suggests, that in addition to MacGPG you also have a custom GnuPG installed, with version 1.4.7 under /usr/local/bin/gpg.
    This is very likely why you are seeing this error

    If you run the following commands in Terminal, everything should be working just like before:

    sudo mv /usr/local/bin/gpg /usr/local/bin/gpg-v1.4.7
    sudo ln -s /usr/local/MacGPG2/bin/gpg2 /usr/local/bin/gpg

    Out of curiosity, which version of GPG Suite were you previously running?

    Hope that helps.

  2. 2 Posted by Alexander on 07 Dec, 2017 02:19 PM

    Alexander's Avatar

    Hey Luke,
    things went back to normal after following your advise. Thanks a lot!
    I have no idea how I managed to get this setup, I have installed GPGTools quite a while ago and updated whenever possible.
    Thanks again,

  3. Support Staff 3 Posted by Luke Le on 07 Dec, 2017 02:22 PM

    Luke Le's Avatar

    Hi Alex,

    very happy that solved your problem. We are currently investigating if a change in the way we select the GnuPG binary to use is triggering this problem for more users.
    It should of course be possible for a custom GnuPG and our MacGPG to co-exists (at least when used from within our tools)

  4. Support Staff 4 Posted by Steve on 07 Dec, 2017 06:31 PM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  5. Steve closed this discussion on 07 Dec, 2017 06:31 PM.

  6. Steve re-opened this discussion on 07 Dec, 2017 07:15 PM

  7. Luke Le closed this discussion on 07 Dec, 2017 07:15 PM.

  8. Steve closed this discussion on 14 Dec, 2017 04:33 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac