GPGServices: Pinentry Mac keeps asking for passphrase

localheinz's Avatar


26 Sep, 2017 10:39 AM


  • committing via git
  • amending a git commit
  • writing an email that gets saved to drafts
  • sending an email

I am getting asked for my passphrase. When I provide it and hit enter, I get asked again the next time one of the events above occur.

I provide my passphrase once, and I am not asked the passphrase again.

Additional info
I updated to GPGTools 2017.1 this morning.

macOS           10.12.6     16G29
GPG Suite       2017.1      2002    (4161887)
GPGMail         2.7         1242    (4272b15)
GPG Keychain    1.4         1377    (3384573)
GPGServices     1.11.1      961     (d6060fa)
MacGPG2         2.2.0       893     (ab15b08)
GPGPreferences  2.1         977     (b1e419a)
Libmacgpg       0.8         819     (c8cf2e0)
pinentry        0.9.7       6       (6aeb033)
  1. Support Staff 1 Posted by Steve on 26 Sep, 2017 11:59 PM

    Steve's Avatar

    Hi Andreas,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    the pinentry requests you are seeing are happening due to the migration from MacGPG 2.0.x to 2.2.0.

    Please read the following KB-article in it's entirety:

    and let me know if that brings you back to the expected state.


  2. 2 Posted by localheinz on 27 Sep, 2017 06:15 AM

    localheinz's Avatar

    Hello Steve,

    thank you for your quick reply.

    If you are referring to

    then that unfortunately did not help solve my problem.

    As you can see in the attached screenshot, there's no option "store in keychain" in the dialog that asks for my passphrase. However, there's an option "store in MacOS keychain" in the GPGSuite preferences pane. This option is selected.

    I have

    • deleted the entry from MacOS keychain that I found when searching for gnupg
    • entered my password probably 50 times

    but it still keeps asking for my passphrase.

    On a related noted, I am glad to hear you are considering asking for money for the software you build. I am happy to pay for it, and support the efforts you put into the product!

    Best regards,


  3. Support Staff 3 Posted by Steve on 27 Sep, 2017 09:36 AM

    Steve's Avatar

    Should you be available, could you hop on our live chat here:

    We can't promise a solution, but we'd like to inspect this problem in more detail.

    All the best

  4. Support Staff 4 Posted by Steve on 27 Sep, 2017 11:37 AM

    Steve's Avatar

    This was solved via live-chat.

    User had the following option in ~/.gnupg/gpg-agent.conf

    Solution was to remove "ignore-cache-for-signing" line from gpg-agent.conf

    After that everything was working as expected.

    I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  5. Steve closed this discussion on 27 Sep, 2017 11:37 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac