GPGMail: Warnings in gpg output breaks the flow in Mail

Aleksandr Vinokurov's Avatar

Aleksandr Vinokurov

25 Sep, 2017 02:39 PM

I’ve got GPG Suite updated today, and GPGMail stopped working, saying smth. like “Key not found”.

I’ve tried to perform gpg operations in console and noticed the complain:

gpg: keyserver option 'ca-cert-file' is obsolete; please use 'hkp-cacert' in dirmngr.conf

but all the process of encryping/decrypting + signing worked in console.

Then I’ve removed the obsolete option from ~/.gnupg/gpg.conf and GPGMail started to work.

Expected
Consider filtering out warnings from gpg output if it still gives the result.

macOS           10.12.6     16G29
GPG Suite       2017.1      2002    (4161887)
GPGMail         2.7         1242    (4272b15)
GPG Keychain    1.4         1377    (3384573)
GPGServices     1.11.1      961     (d6060fa)
MacGPG2         2.2.0       893     (ab15b08)
GPGPreferences  2.1         977     (b1e419a)
Libmacgpg       0.8         819     (c8cf2e0)
pinentry        0.9.7       6       (6aeb033)
  1. Support Staff 1 Posted by Steve on 11 Oct, 2017 05:04 PM

    Steve's Avatar

    Hi Aleksandr,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Thanks for taking the time to report this issue and sharing how you managed to resolve it.

    We would like to understand the issue in more depth. Would it be possible for your to re-add the faulty option and create a screenshot of the error you are then seeing in Mail.app?

    That would be helpful.

    All the best,
    steve

  2. Support Staff 2 Posted by Steve on 06 Nov, 2017 05:10 PM

    Steve's Avatar

    Hi Aleksandr,

    this issue has been fixed. If you want to test the fix, please download our latest nightly GPG Suite. That page also has sig and SHA1 to verify the download.

    Please do check if your sec/pub key is still valid:

    1. open GPG Keychain
    2. double click your sec/pub key
    3. create a screenshot of the key tab (⇧⌘4 + drag w mouse)
    4. create a screenshot of the subkey tab
    5. attach both screenshots to your discussion by visiting it in your browser

    Should your key have expired, please re-new the expiration date in the key tab.

    To renew the subkey, open the subkey tab, click the cogwheel and change the expiration date

    After that send a signed and encrypted test mail to yourself. Are you able to decrypt and verify the signature successfully?

    In case your key resides on the public key servers, don't forget to upload your updated key, so that the changes are reflected on the key servers.

    Best regards,
    Steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  3. Support Staff 3 Posted by Steve on 26 Feb, 2018 01:51 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  4. Steve closed this discussion on 26 Feb, 2018 01:51 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac