Apple Mail encrypts draft messages despite repeatedly unchecking "encrypt drafts" option

Vera's Avatar


14 Aug, 2015 04:48 PM

GPGMAIL Version 2.5 Build 1009

Apple Mail on Mac OS X 10.7.5

Mail has recently started encrypting draft messages (it did not do this prior to an early July update of the PGP suite). I have repeatedly gone into preferences and unchecked the "encrypt drafts" option but it keeps encrypting drafts and automatically rechecking the "encrypt drafts" option.

I do not want my drafts encrypted - I keep them on my mail server and access them via multiple devices and web mail. If they are encrypted I cannot open, continue to edit or send a draft that was created or opened using Mail. The desired behavior is how things worked prior to early July, which is approximately when I updated my GPGMail.

When I uncheck the "encrypt drafts" option then start and save a new draft it is encrypted. The "encrypt drafts" option appears to stay unchecked after closing and reopening Mail preferences, but new drafts are still encrypted. After quitting and reopening Mail (with and without rebooting) the checkmark reappears. Both "encrypt new messages by default" and "sign new messages by default" are unchecked.

First screen shot is of preferences file with "encrypt drafts" unchecked (but drafts still automatically encrypt); second screenshot is of preferences file after quitting and reopening Mail: despite having unchecked it before quitting, "encrypt drafts" is checked again.

  1. Support Staff 1 Posted by Steve on 14 Aug, 2015 04:54 PM

    Steve's Avatar

    Hi Vera,

    could you please download and install our latest nightly build and see if the problem persists. That page also has sig and SHA1 to verify the download.

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Vera on 14 Aug, 2015 05:05 PM

    Vera's Avatar

    Thanks - I have installed the nightly build. This time when I went to uncheck the "encrypt drafts" option a warning message popped up. It had not done so with the previous installed version of GPGMail. I started a draft, saved it, and it was not encrypted.

    Tested further by quitting Mail, restarting, starting a draft, saving ... and no more automatic encryption.

    Thanks for your help ... I hope this is a pretty stable (nightly) build!


  3. Support Staff 3 Posted by Steve on 14 Aug, 2015 09:11 PM

    Steve's Avatar

    Vera, you will not have to wait too long for the next stable which includes this fix. Currently the nightly should be pretty stable.

    Glad, this is solved for you. I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  4. Steve closed this discussion on 14 Aug, 2015 09:11 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac