GPG on mac OSX 10.6.8 (snow leopard wont work

Paul's Avatar


04 Jan, 2013 02:42 AM

I have uploaded GPG twice and when it generates the 1st key it asked for my passphrase which it refuses to accept even though I have used every password I have for both my mail app and my gmail and my desktops password.
I also get a notification when I open mail that GPG plug in has been disabled please contact GPG for a version that is compatible with mail app 4.6
Given that i don't think I can change my mail without uploading a new OSX and GPG technical support to date have been as useful as tits on a bull how to I get simple encryption for personal emails surely it can't be that hard but I have been trying since last year

  1. Support Staff 1 Posted by Luke Le on 04 Jan, 2013 07:52 AM

    Luke Le's Avatar

    Hi Paul.

    to fix your problem saying that the plugin has been disabled, please install the latest version of GPGMail for Snow Leopard from our website:

    (Direct Link:

    Best is if you first install the GPGTools-Installer from and after that the GPGMail-1.4.1 from the link above.

    When you generate a key and are asked for a passphrase you don't have to enter an existing one but simply specify a new one.

    If all this doesn't help, please elaborate a bit better where things seem to fail, since it's not entirely clear from your message.

  2. 2 Posted by Paul on 05 Jan, 2013 09:30 PM

    Paul's Avatar

    Hi Luke
    Thanks for these solutions I uploaded the GPG Tools installer but the link to GPG mail1.4.1 dmg failed to take me to the link and the top link took me to an upgrade that required Mac OSX 10.7 and I am on 10.6.8 I will try to generate a key from the new GPG but without having changed anything else????
    Thanks again Luke I do understand that if Apple did their job and supported bundles like these we would not be having this conversation

  3. 3 Posted by Paris on 06 Jan, 2013 07:53 AM

    Paris's Avatar

    I'm having the same problems. I have gone to and downloaded the latest installer twice (the last time just as Luke suggested). First time, I got the same message as Paul. The second time I got a message saying that mail quit unexpectedly...did I want to reopen. Then it said "invalid crypto engine...GPGMail cannot work. It didn't find GnuPG (/usr/local/MacGPG2/bin/gpg2) with at least version 1.4.0. Please quit Mail, install a matching GnuPG version, then restart Mail."

  4. Support Staff 4 Posted by Steve on 07 Jan, 2013 11:05 AM

    Steve's Avatar

    Paul, I'm not sure what you are currently trying to do. The GPGMail 1.4.1 link, that Luke posted, works fine for me. But the best is, to simply run the nightly GPGTools Installer from here:

    Hey Paris, same for you: pls also try our nightly GPGTools Installer.

    Please let us know if that works.

  5. 5 Posted by Marco A A de Ol... on 07 Jan, 2013 06:36 PM

    Marco A A de Oliveira's Avatar


    I have:
    (1) a similar problem (Mail requesting a 4.6 compatible version of gpg2), compounded with:

    (2) a broken enigmail 1.5 extension on thunderbird 17 ("bad passphrase").

    I am running OS X 10.6.8.

    I had installed gnupg before gpgtools, and it is still there apparently, since commanding "gpg --version" reports its home directory as "~/.gnupg".

    MacGPG versions 1 and 2 are accounted for, residing in corresponding subdirectories under the "/usr/local/" directory.

    I list the steps I took below:

    Initially I had enigmail 1.4 running fine under Thunderbird 17, as well MacGPG (pre-GPGtools installer).

    • First I installed GPGTools. And that broke enigmail: it could not find "gnupg/S.gpg-agent". A google search turned up some posts, with the most recent dating back to 2010...
    • I then tried the "fix" button in GPGPreferences. Enigmail still broken.
    • Next, the nightly build of GPGTools. No dice.
    • I then removed enigmail and installed enigmail 1.5. Broken, but now reporting "bad passphrase". The enigmail keymanager still displays all the keys.
    • I then found the "GPGTools" fix button. To no avail.
    • Having a broken enigmail/Thunderbird, I fired up (GPG)Mail, but was greeted with apparently the same message that the OP saw.

    That's at where I am now.
    I noticed that "GPGPreferences" takes quite a bit of time (more than 5 minutes) to open from "System Preferences".

    Thanks for your attention and possible assistance.

    Happy 2013!

    Marco A. A. de Oliveira

  6. Support Staff 6 Posted by Steve on 10 Jan, 2013 01:06 PM

    Steve's Avatar

    Marco, could you try the steps I've described above your post?

    Currently we have 3 people with this problem. Paul & Paris, were you able to try the nightly version of the GPGTools Installer?

  7. 7 Posted by Marco A A de Ol... on 11 Jan, 2013 05:42 PM

    Marco A A de Oliveira's Avatar

    Hi Steve,

    Thanks for your help!

    I tried with the nightly version of GPGTools (20130111-0015) and while there is an error, there was considerable progress: GPGMail opens fine and Enigmail/TB is OK. Yay!

    The error is now that GPG Keychain Access is unable to recognize/import existing GPG keys (skip to {CURRENT_ERROR} marker; I used curly brackets to avoid confusing the formatting filter).

    I detailed the steps I followed below. The end of the message has some signing-off text (after {END INSTALL}).

    OK, baseline first.


    • I have uninstalled GPGTools;
    • I have an iMac (10,1) with 4GiB and running OS X 10.6.8;
    • I have Mail 4.6;
    • I also have Thunderbird 17.0.2 and Enigmail 1.5 (20121227-0013). The latter are running fine, after I installed MacGPG which uses GPG 1.4.9 (residing in directory /usr/local/bin/gpg). All keys are visible and usable.

    • Quit Thunderbird.


    {START INSTALL} Now I will install the nightly version of GPGTools (20130111-0015).
    Note: Enigmail not shown in the list of applications to be installed by GPGTools (expected).

    • Checking for gnupg: still in /usr/local/bin/gpg.

    • Opening TB. Enigmail working. Quit TB.

    • Opening Mail. Warns that there are no keys. Strange.


    • Opening GPG Keychain Access. Unable to import a whole keyring.

    • Switching to Enigmail key management to export keys into .asc files (TB now open).

    • GPG Keychain Access unable to import individual file containing secret and public keys. Error message:

    Key Import Failed
    Import failed!
    Code = 0
    Error text:

    Note: there are approximately three blank lines after the Error text: section.

    • Attempting to import same file, however with txt extension instead of asc. Failure: same error message.

    • Inspection of the ASCII armored key file reveals standard format used, with -----BEGIN PGP PUBLIC KEY BLOCK-----and -----END PGP PUBLIC KEY BLOCK----- tags.

    • Trying to import an ASCII armored key file with only the public keys. Failure: same error message.

    • Trying to import an ASCII armored key file with only one public key. Failure: same error.

    • Trying one public key import with TB closed (quit). No dice.

    • Trying Fix GPGTools button in GPGPreferences (quit GPG Keychain access).Output:

    GPGTools fix result:
    [gpgtools] Fixing Enigmail...
    [gpgtools] Fixing Preferences...
    [gpgtools] Fixing Services...
    [gpgtools] Fixing Mail...
     * Writing '4' to ''...
     * Writing '4' to '' as 'marcoantonioassfalkdeoliveira'...
     * Writing '4' to ''...
     * Fixing permissions in '/Users/marcoantonioassfalkdeoliveira/Library/Mail/'...
     * Fixing permissions in '/Library/Mail/'...
    [gpgmail] is installed
    [gpgmail] Setting the correct permissions in '/Library/Mail/Bundles//GPGMail.mailbundle'...
    [gpgmail] Warning: could not patch GPGMail. No UUIDs found.
    [gpgtools] Fixing GPG...
    • Opening GPG keychain access. No keys listed. Trying import. Failure importing TXT and ASC extension ASCII armored key file with one public key. Same error message.


    Not sure what to do next. Request further instruction. :-)

    I hope I have supplied sufficient information.

    Thank you for your help and attention.

    Marco A. A. de Oliveira

  8. 8 Posted by Phillip Alday on 14 Jan, 2013 10:00 AM

    Phillip Alday's Avatar

    I have also been having a similar problem. Manually installing MacGPG2 helped a bit -- I'm now able to import my keys in GPG Keychain Access, but Enigmail on TB 17 still can't seem to find my keys. I get stuck in a loop on the No OpenPGP Key Found (this, despite GPG Keychain Access clearly showing my key), so I select the import option and select my key file, but am immediately redirected back to the No OpenPGP Key Found page. I've also tried reinstalling Enigmail.

  9. Support Staff 9 Posted by Steve on 18 Jan, 2013 04:39 PM

    Steve's Avatar

    Marco, thanks for your detailed description. That is helpful. I'm still a bit puzzled that you are still experiencing issues importing your keys. I am aware that this was an issues but it should not be with the latest GPG Keychain Access nightly. Currently that is GPG Keychain Access-179n.dmg.

    Could you simply re-try with that latest GPG Keychain Access nightly?

    @Philip: This sounds indeed very strange. Could you please install both MacGPG2 and GPG Keychain Access from the nightly page? MacGPG2 has received a couple of fixes in the last few days. Let us know if they are sufficient to solve your problem. As for Enigmail not accepting your keyring, maybe you could also try getting in touch with the enigmail folks:

    Please provide feedback how things go and we'll further look into it.

  10. 10 Posted by Phillip Alday on 22 Jan, 2013 12:11 AM

    Phillip Alday's Avatar

    I installed everything from the nightly page after reading elsewhere that they were a few long standing bugs in the release builds that had been largely fixed in the nightlies. My last post was using the then current nightlies; I haven't yet updated again.

    I figured out what was causing at least part of the problem on my end: one of the keys had been revoked. However, things were just failing silently and not giving any warning about me attempting to use a revoked key and the key was not showing as revoked on that computer. Speaking of which -- the key was revoked (on another computer) by a stray double click on the revoke file without asking for confirmation.) So, for me the fix I would like to see is more verbosity in the error conditions. (Where) Should I file an issue about this?

    As far as the Enigmail bit goes, I suspect it was half of this issue with the revoked key -- the revoked key was failing silently, which is what put me in that little loop; I'm not sure how this was interacting with loading my keychain. Both keys (the revoked one and its non-revoked successor) were present in my keychain, which could not be loaded; however Enigmail had no trouble loading the valid key directly from file.

    I unfortunately no longer remember the exact order of everything I did, but the common issues for my problem appear to be (1) dealing with revoked keys [which is probably somewhat related to the issues refreshing from key servers I've read about elsewhere] and (2) silent failure / lack of verbosity. The nightly builds were definitely a step in the right direction. Any word on when there'll be a new (point) release?

  11. Support Staff 11 Posted by Luke Le on 23 Jan, 2013 06:16 PM

    Luke Le's Avatar

    Hi Phillip,

    thanks for the detailed description! This might be very helpful for others.

    the GPGMail 1.4.1 will probably be the last version for Snow Leopard since we unfortunately don't have the resources to support 10.6 any longer.
    There's a very slim chance that we'll backport GPGMail 2.x in the future, but it's not high on our priority list.

  12. 12 Posted by Marco A A de Ol... on 24 Jan, 2013 12:03 PM

    Marco A A de Oliveira's Avatar

    Hi Steve,

    Thanks for helping.

    I installed the latest GPG Keychain Access nightly (currently 184n) and attempted importing several ASCII armored key files, as I had in my earlier session, but I was met with the same error message.

    Using the "Fix GPGTools" service in GPGPreferences generated the same log message, and had no apparent effect on GPG Keychain Access behavior (as to importing keys).

    Given Phillip's description/solution, I checked my keys and none have been revoked, so I am experiencing a different scenario.

    Marco A. A. de Oliveira

  13. 13 Posted by Paul Webster on 24 Jan, 2013 11:36 PM

    Paul Webster's Avatar

    I just gave up as there was no way I could spend anymore time wasting on
    the installation at the moment, which is very disappointing as I really
    wanted GPG on my Mac
    When someone gets a break thru I will try again

  14. Support Staff 14 Posted by Steve on 25 Jan, 2013 07:33 PM

    Steve's Avatar

    Marco: Please open a new discussion and set it to private. Then please attach one of the key files giving you trouble so we can test this and try to reproduce the problem.

    Paul: I already responded to you but have not seen any reply so far from you. You could just retry running the latest nightly of the GPGTools Installer and see if it solves your problem. If you're busy you might wanna re-try later. All we can offer is the latest nightly that has been working for all 10.6 users so far.

    I'm closing this discussion, since it's rather hard, trying to keep track of separate issues in one single discussion. Anybody with remaining issues, please open a new discussion and we'll try to get you fixed.

    Best, steve

  15. Steve closed this discussion on 25 Jan, 2013 07:33 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac