problem with agent: Timeout - gpg: skipped

nikmon's Avatar


20 May, 2015 08:15 PM

GPG Keychain 1.2b6 (1057b)

Unfortunately we can't handle the error at this point.

Should your problem persist, please contact us at with the following error description:

gpg: problem with the agent: Timeout
gpg: skipped "25CECD2D889FD027BDF0752EB651260BA8639974": Operation cancelled
gpg: signing failed: Operation cancelled

What did you expect instead

Email should have been send

Describe steps leading to the problem.

  1. Installed gpg keychain
  2. added a new key
  3. send an email successfully
  4. Was prompted for my ridiculously long passphrase
  5. Answered yes, add it to my apple keychain
  6. changed the passphrase
  7. send another email - failed - bad passphrase (see new one)
  8. typed the old one, mail was send (i think)
  9. tried to change passphrase - could not
  10. tried to send new email - could not, neither phrase would work
  11. revoked old key, created new ket with new passphrase - this is where I am stuck
  1. Support Staff 1 Posted by Steve on 22 Jul, 2015 04:26 PM

    Steve's Avatar

    Hey nikmon,

    sorry for not responding earlier.

    Did you update to GPG Suite 2015.06 in the meantime? Are you still seeing this problem with your new key?

    Could you do a simple text encryption in TextEdit to test your setup?

    Does that work with your new key?

    All the best,

  2. 2 Posted by nikmon on 05 Aug, 2015 12:34 AM

    nikmon's Avatar

    Thank you , all is working fine after the update.


  3. Support Staff 3 Posted by Steve on 06 Aug, 2015 11:06 AM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  4. Steve closed this discussion on 06 Aug, 2015 11:06 AM.

  5. Steve closed this discussion on 05 Feb, 2016 02:33 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac