MacGPG2 #148: gpg:problem with the agent:no pinentry

david's Avatar

david

08 Mar, 2015 08:29 PM

whatever I do- I get this error: "gpg:problem with the agent:no pinentry"
Tried: gpg --encrypt; gpg --gen-key, etc.
Started gpg-agent.
Still the same problem.
gpg version 2.0.25
libgcrypt 1.5.3

Can somebody explain what this error message means (could not find it in help), and how to work around it.
Thank you

  1. Support Staff 1 Posted by Steve on 14 Mar, 2015 11:41 PM

    Steve's Avatar

    Hey David,

    thanks for taking the time to report this problem. It is a known issue and I have connected this discussion with the existing ticket. We have yet to find out, what exactly is causing this, but assume it is related to sleep / wake behavior of the mac. Are you using sleep mode?

    The workaround is, to simply restart your mac and you should be back in working state.

    We'll update this discussion as soon as we have news about this issue.

    Since you are using an old version of MacGPG2, please do download and install GPG Suite b5 from our homepage since it includes important updates and fixes.

    All the best,
    steve

  2. Steve closed this discussion on 03 Jun, 2015 01:03 PM.

  3. Steve re-opened this discussion on 05 Jul, 2015 03:58 PM

  4. Support Staff 2 Posted by Steve on 05 Jul, 2015 03:58 PM

    Steve's Avatar

    Hi David,

    good news. We think, this issue has been fixed. If you want to test the fix, please download our latest nightly GPG Suite. That page also has sig and SHA1 to verify the download. It would be very helpful, if you can provide feedback, as to whether the fix works as expected.

    If you have other questions you can open a new discussion any time.

    Best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  5. Steve closed this discussion on 24 Jul, 2015 09:17 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac