GPGMail: 'Signing your message failed because an unknown error has occured'

Jannik's Avatar


03 Mar, 2015 03:47 PM

Mac OS X: 10.10.2 (14C109)
MacGPG2: 2.0.26b5, 791b (tried nightly)
GPG Keychain: 1.2b5, 1010b
GPGServices: 1.10b5, 760b
GPGPreferences: 1.5b5, 761b
GPGMail: 2.5b5, 891b

When trying to send a signed mail, I get the following error message:

Unfortunately we can't handle the error at this point.

Should your problem persist, please contact us at with the following error description:

gpg: problem with the agent: Unknown option gpg: skipped "548301AF478FC5D10654BFBBC9CF96627C3B6E42": Operation cancelled gpg: signing failed: Operation cancelled

I tried the nightly versions, a reinstall and restart. I uninstalled gnugp2 from Homebrew.

When sending the mail just with encryption to myself, I get the following error when I try to read it:

An unknown error occurred while decrypting this message.

GPG error message:
gpg: problem with the agent: Unknown option
gpg: encrypted with 4096-bit RSA key, ID <removed>, created <removed>
gpg: public key decryption failed: Operation cancelled
gpg: decryption failed: No secret key

Please contact us, including the GPG error message, at
  1. 1 Posted by Jannik on 03 Mar, 2015 03:50 PM

    Jannik's Avatar

    Additional information: When using the Service in Finder I get

    Encrypt/sign failed! (Unknown option)
    Code = 174

    My keys are created following this article:

  2. Support Staff 2 Posted by Luke Le on 16 Mar, 2015 11:32 AM

    Luke Le's Avatar

    Hi Jannik,

    could you please post the contents of your ~/.gnupg/gpg-agent.conf and ~/.gnupg/gpg.conf file?


  3. Support Staff 3 Posted by Steve on 25 Mar, 2015 12:24 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  4. Steve closed this discussion on 25 Mar, 2015 12:24 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac