importing a public key

Jerome's Avatar


21 Nov, 2011 02:42 PM


I'm using gpgtools-20111114 with mac OS X 10.6.8.

I can't import a key throught textedit : I select the whole text and i select "OpenPGP : Imprt Key, but nothing happens.

If i try to save the file with a name like ABCD.asc, it doesn't work either.

The key has been sent by a user not using gpgtools (but probably GPG4win) via email.

it starts with :

 Version: GnuPG v2.0.17 (MingW32)

When i try to import a key from a user of gpgtools, i have no problem.
Any idea ?

  1. Support Staff 1 Posted by Steve on 21 Nov, 2011 10:32 PM

    Steve's Avatar

    Sounds interesting ;)

    You could try using the key servers or does your contact not want to use those? If so, why not (I'm just curious to learn the reasons why people refrain from using the key servers).

    Are you using GPG Keychain Access? If so simply drag & drop the txt file into the main window and the key should get imported.

    I just tested the GPGServices as well. And they worked fine for me. Right click the txt file Services > OpenPGP: Import

    1 key imported. Not sure why that is not working on your end. Do you get any error message?

    Let us know if this works.

  2. 2 Posted by Jerome on 22 Nov, 2011 07:41 AM

    Jerome's Avatar

    Hi Steve,

    Thank you for the answer. I tried the drop and drop, without success.

    I do use the key servers and I asked my contact to do it as well, but he didn't so far (and I don't know the reason for that).

    The GPGservices do work with most keys, but not with this one. I don't get any error message in the GPG Keychain Access windows. Maybe I can send you the key so that you try ?


  3. Support Staff 3 Posted by Steve on 22 Nov, 2011 12:59 PM

    Steve's Avatar

    Hi Jerome,

    thanks for trying out this suggestion and sry it didn't work.

    If it is ok with the pub key owner feel free to either attach the pub key to this thread (so our team can do some further testing with that specific key) or mail it directly to me to steve AT gpgtools DOT org

    Cheers :)

  4. Support Staff 4 Posted by Steve on 22 Nov, 2011 02:48 PM

    Steve's Avatar

    Dear Jerome,

    we have found the problem with this file. It is an .rtf format file. GPG Keychain Access currently does not accept those files. And it is not an ideal format to transfere keys. That should rather be done in the .txt file format. The txt can then be renamed to asc and in both cases an import will work fine.

    When you export a key with GPG Keychain Access this is exactly what happens.

    So please tell your friend 1) to think about usage of the key servers and 2) to export pub keys only to the txt format and/or the asc format or txt and in no case .rtf (or asc that contain an rtf).

    Hope this helps and you can finally use your friends key.
    All the best,

  5. Steve closed this discussion on 22 Nov, 2011 02:48 PM.

  6. Steve re-opened this discussion on 22 Nov, 2011 02:48 PM

  7. 5 Posted by Jerome on 22 Nov, 2011 03:25 PM

    Jerome's Avatar

    Thank you for your help and for your work !

    Best regards,


  8. Support Staff 6 Posted by Steve on 22 Nov, 2011 03:35 PM

    Steve's Avatar

    Assume everything if working fine for you now?

    If you need further assistance feel free to re-open or open another discussion.

    Glad, things are now working :)

  9. Steve closed this discussion on 22 Nov, 2011 03:35 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac