MacGPG2 #148: Decrypt Error Code

Reuben's Avatar

Reuben

03 Jan, 2015 11:27 AM

I am having a similar issue. However I am not receiving any error or dialog box. I am using the exact steps as Aaron. I have downloaded and installed GPG Suite Beta . I have noticed that when I restart my computer the services of encryption and decryption work but only for a time. If my computer goes to sleep when I return none of the services are functional.

Describe steps leading to the problem.

Copy past message
high light message
Using short cut key, prom decrypt, followed by error code
  1. Support Staff 1 Posted by Steve on 03 Jan, 2015 02:39 PM

    Steve's Avatar

    Hi Reuben,

    thanks for the report. Are you able to determine exact steps to trigger this issues?

    We have a suspicion about this problem: At the moment it's highly likely this is related to sleep mode and pinentry getting stuck. A non-active pinentry-dialog is still visible and a new one is requested, the new one times out, because the old one is still waiting for a response.

    Getting to a point where we have exact steps to trigger this issue, would be a tremendously important step on the way to fix this. So if you can determine a pattern, please do let us know.

    Also can you please post a screenshot of the error message you are seeing and check console.app if it spits out related error messages.

    All the best,
    steve

  2. 2 Posted by Reuben on 03 Jan, 2015 05:43 PM

    Reuben's Avatar

    Steve, the only steps that I've taken are what Aaron first mentioned. The only key details I would add is that I am using OS X Yosemite 10.10.1 and the program I am using is TextEdit 1.10(319).

    I insert text into TextEdit. Highlight inserted text. Right Click>Services>Encrypt/Decrypt.

    Nothing happens. No error message. But if I reboot my computer and use any GPG service before the computer sleeps everything works fine. Once the computer goes to sleep and I wake it, the services (encrypt/decrypt) no longer function.

  3. Support Staff 3 Posted by Steve on 04 Jan, 2015 08:46 PM

    Steve's Avatar

    Ok, and it always happens? Start your computer > encryption in TextEdit works. Sleep the machine, wake up, and encryption no longer works in TextEdit?

    I just tried this and it worked fine even after a short period of time.

    Besides the above question, after trying that out, could you try storing your passphrase in the OS X keychain (pinentry has an option for that) for a while and see if that changes anything regarding this issue when unsing sleep / wake function.

    If you then want to remove your key from the osx keychain, GPGPreferences > Settings has a button to remove stored passphrases.

    Looking forward to hearing more on your test results,
    steve

  4. 4 Posted by Reuben on 05 Jan, 2015 05:05 AM

    Reuben's Avatar

    Sleep the machine, wake up, and encryption no longer works in TextEdit?

    Correct. GPG loads fine but none of the "right click" service function.

    I attempted to store my passphrase in the OS X keychain. No change. I'm going to back up my keys and re-install on my MacBook Pro.

    I have exported my keys and installed GPG suite on my iMac no issue in usage after waking that machine and using the services.

    The issue maybe specific just to my MacBook.

  5. Support Staff 5 Posted by Steve on 05 Jan, 2015 09:33 AM

    Steve's Avatar

    That is an important info. Can you give us the exact model of the MacBook this is happening on? (click the apple in the top left menu, then "About this mac". should read sth like MacBook Pro (15 Inch, Late 2013 or such))

    This might be model specific because I know for sure, that on some MacBooks this does not happen, even after they go to sleep several times.

  6. Steve closed this discussion on 02 May, 2015 07:29 PM.

  7. Steve re-opened this discussion on 05 Jul, 2015 03:11 PM

  8. Support Staff 6 Posted by Steve on 05 Jul, 2015 03:11 PM

    Steve's Avatar

    Hi Reuben,

    good news. We think, this issue has been fixed. If you want to test the fix, please download our latest nightly GPG Suite. That page also has sig and SHA1 to verify the download. It would be very helpful, if you can provide feedback, as to whether the fix works as expected.

    If you have other questions you can open a new discussion any time.

    Best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  9. Steve closed this discussion on 24 Jul, 2015 09:23 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac