GPG Keychain not working on 10.10.1 (MacGPG2 #141 FIXED)

Gerd's Avatar


27 Nov, 2014 10:52 AM

Same here. Actually, for me it does not work at all on Yosemite. (10.10.1)
Trying to import my old saved key comes back with an error message (yes, the "not signed" stuff).
Trying to download a key from the key-server brings nothing back (except an empty windows)
Trying to create a new key, come up with the same error as you have.

  1. Support Staff 1 Posted by Steve on 27 Nov, 2014 10:59 AM

    Steve's Avatar

    Hi Gerd,

    I have split your comment into a separate discussion to keep things lean and clean.

    Could you please open GPGPreferences, set everything except for GPGMail to nightly and check all the tools for updates. Download and install if any do show up.

    Can you then test again and see if anything has improved?

    If not, please open and see if it gives any error messages when you are trying those operations that are currently not working.

    All the best,

  2. 2 Posted by Gerd on 27 Nov, 2014 08:23 PM

    Gerd's Avatar

    Hi steve,
    did everything as you said. Updated to nightly build and tried it again.
    No improvement.

    My old key disappeared, but I have (had?) a backup as described in your handbook. but this backup cannot be imported due to the "not signed bla bla bla... goto link...."
    which doesn't help as I thus cannot revoke my key from the server.

    When trying to import it, the following error message is in the console:
    27.11.14 21:12:59,562 GPG Keychain[10640]: Exception: I
    mport failed!
    Code = 0
    27.11.14 21:12:59,563 GPG Keychain[10640]:
    Error text:
    Status text:

    The download of a key from the server does also not work, but gives the following error:
    27.11.14 21:12:07,428 ReportCrash[10716]: Too many crashes in rapid succession! No crash report being written for pid 10722
    +10 lines with "ReportCrash: Removing excessive log..."

    Have following config:

    Modellname: iMac
    Modell-Identifizierung: iMac7,1 Prozessortyp: Intel Core 2 Duo Prozessorgeschwindigkeit: 2,8 GHz Anzahl der Prozessoren: 1 Gesamtanzahl der Kerne: 2 L2-Cache: 4 MB Speicher: 4 GB Busgeschwindigkeit: 800 MHz Boot-ROM-Version: IM71.007A.B03

    Wis Yosemite 10.10.1

  3. Support Staff 3 Posted by Luke Le on 27 Nov, 2014 08:32 PM

    Luke Le's Avatar

    Hi Gerd,

    would you consider trying something with us for a second?
    I think I'm currently working on exactly the problem you're having.

    If yes it's best if you join our live chat:

  4. Support Staff 4 Posted by Steve on 28 Nov, 2014 02:23 PM

    Steve's Avatar

    Hi Gerd,

    this issue is fixed. Please download and install the MacGPG2 nightly from and see if that fixes the problem.

    All the best, steve

  5. 5 Posted by Gerd on 28 Nov, 2014 09:43 PM

    Gerd's Avatar

    Hi Steve,
    yes, the issue got fixed with the nightly built.

    All the best

  6. Support Staff 6 Posted by Steve on 29 Nov, 2014 07:58 AM

    Steve's Avatar

    Great :)

  7. Steve closed this discussion on 29 Nov, 2014 07:58 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac