Encrypt button in mail.app is greyed-out and will not work. Signing works fine.

Marcus Eubanks's Avatar

Marcus Eubanks

23 Jul, 2014 06:02 PM

GPGMail 2.1 Build 601

When I compose messages, I can select the box to sign messages, and they are properly signed. The encrypt button remains greyed-out, and clicking on it does nothing.

Please describe what you did expect instead

I expect encryption to be functional.

If you remember, please describe the steps leading up to the problem.

  1. It broke when I installed the most recent version of GPGMail. Perhaps I can revert?
  1. Support Staff 1 Posted by Steve on 23 Jul, 2014 06:09 PM

    Steve's Avatar

    Hi Marcus,

    which email did you enter for the recipient field? And did you check GPG Keychain Access if you do indeed have a public key for that mail address?

    If that is the case and you still are seeing odd behavior, please download and install our latest nightly build and see if the problem persists.

    You can find sig and SHA1 on the GPGTools Nightlies page.

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Marcus Eubanks on 23 Jul, 2014 06:20 PM

    Marcus Eubanks's Avatar

    Good afternoon Steve -

    I did indeed check to make sure that I have working keys for the recipients.

    I even tried to send an email from one of my accounts to another, both of which have keys associated with them. I have no difficulty signing, but for some reason it won’t let me hit the lock button to encrypt.

    When I view the signed email, it is reported as being properly signed.

    I’ll try the newest build.

    Best -
    Marcus

  3. Support Staff 3 Posted by Steve on 23 Jul, 2014 06:21 PM

    Steve's Avatar

    Marcus, would you be willing to do a screensharing session? If so, please hop on our live chat: http://www.hipchat.com/gi8zHW4K3

    If not, what color are you seeing under Mail.app > preferences > GPGMail for the color indicator bubble?

    Can you try sending a mail to yourself? Does that work?

    Also try encrypting a text message to yourself.

    best, steve

  4. 4 Posted by Marcus Eubanks on 24 Jul, 2014 06:30 AM

    Marcus Eubanks's Avatar

    So: in the end, Steve kindly took a look at my machine and tentatively concluded that GPGMail was acting funny. Attached is a screen shot of the error that we generated.

    . . .

    In the end it seemed more prudent to revoke my (relatively) insecure 1k keys and generate a new one which incorporates both of my active email addresses.

  5. Support Staff 5 Posted by Steve on 24 Jul, 2014 12:10 PM

    Steve's Avatar

    Marcus, another thing that could be causing the issue, is that the subkey of your 1k key might have been expired.

    Where you able to create a new 4k (recommended) key already? Did that then work? (don't forget to revoke the old and weak keys.

    Best, steve

  6. 6 Posted by Marcus Eubanks on 24 Jul, 2014 03:24 PM

    Marcus Eubanks's Avatar

    Interesting: going back and looking at the subkeys, looks like you're right: they were expired.

    In any event, I have indeed created a new 4k key and revoked the two offending keys on the pgp.mit.edu keyserver.

    The new key works as expected.

    Again, my thanks for your help.

  7. Support Staff 7 Posted by Steve on 28 Jul, 2014 10:25 AM

    Steve's Avatar

    Perfect. Glad, this is solved for you. We def. need a better error messsage and have a ticket for that:

    https://gpgtools.lighthouseapp.com/projects/65684/tickets/243

    I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  8. Steve closed this discussion on 28 Jul, 2014 10:25 AM.

  9. Steve re-opened this discussion on 03 May, 2015 09:15 AM

  10. Steve closed this discussion on 03 May, 2015 09:16 AM.

  11. Steve closed this discussion on 27 Aug, 2018 12:31 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac