In TextEdit, when selecting a service from right click menu... nothing happens.

DGN's Avatar

DGN

22 May, 2014 01:37 AM

So! I have been using GPGTools for almost a year, but I am suddenly coming across problems!
I pretty much only use this in TextEdit, so I tried right clicking using mail to do different things (encrypt/decrypt/import key) but nothing is doing anything.

Basically the text freezes for a few seconds - I can't click or scroll or do anything with it, but the cursor looks normal.
Not even an error message.

Anyway, I updated to the latest version and I'm still having this problem. Did the uninstall and reinstall thing, no luck.
Any ideas? At this point I am really desperate. I like GPGtools and I don't want to switch to another program, but I'm not sure what else to do.
Hopefully I'm making an easily correctible mistake. Let me know if you can help!

  1. Support Staff 1 Posted by Steve on 22 May, 2014 07:17 PM

    Steve's Avatar

    Hi DGN,

    this sounds like you are currently running the nightly. We've recently chanced quite a few things around the tools and at the moment there exists a known issue preventing GPGServices from starting. While chances are good, this will be fixed soon (~next 7 days, rather sooner but note we do not give ETAs!), to prevent this from happening, please re-download the stable GPG Suite from our homepage and run that installer.

    Let me know if that brings back a working GPGServices.

    On a sidenote: are you using mail.app as your email-client? If so, why not use the very easy to use GPGMail OpenPGP plugin for Mail.app? It's a lot simpler to use than GPGServices.

    While it provides different functionality it's a great addition.

    All the best,
    steve

  2. 2 Posted by DGN on 23 May, 2014 12:31 AM

    DGN's Avatar

    Uninstall/ reinstall (from the one that's not the -latest.dmg) did the trick.
    Thanks!

  3. Support Staff 3 Posted by Steve on 23 May, 2014 01:56 PM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Please stay away from the nightly build for a week or so. Should be fixed then. And then you're welcome again to try the latest (but a bit more unstable GPG Suite).

    Should you need help with setting up GPGMail, let us know!

    Best, steve

  4. Steve closed this discussion on 23 May, 2014 01:56 PM.

  5. Support Staff 4 Posted by Steve on 23 May, 2014 04:44 PM

    Steve's Avatar

    FYI should be fixed now in nightly. If you want download and install our latest nightly build and see if the problem persists.

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  6. Steve closed this discussion on 23 May, 2014 04:44 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac