Error Code=0 on all operations with the keyserver

Tony's Avatar

Tony

22 Apr, 2014 05:15 PM

I recently installed gpg tools on my mac but I'm consistently getting error code 0 when communicating with the keyserver. I've tried new keyserver locations even the http and port 80 ones and still no luck. I'm running Version 1.1.3 (601)

Code = 0

Error text:
gpg: keyserver timed out
gpg: keyserver send failed: Keyserver error

  1. Support Staff 1 Posted by Steve on 30 Apr, 2014 05:37 PM

    Steve's Avatar

    Hi Tony,

    interesting. Do I understand correctly, that you did try several key server from the dropdown list at GPG Keychain Access > Preferences > Key server? If they all fail at least we know it's not a single key server which is broken or unavailable.

    What you describe sounds like something is generally blocking access to those locations.

    Are you behind a firewall? Sounds like you've already found and also tried what's described here: http://support.gpgtools.org/kb/faq/im-behind-a-firewall-eg-in-a-big...

    Anything key server related blocked in Little Snitch if you use that? Maybe accidentally all GPG Keychain Access traffic was blocked?

    Check if you can connect to a key server when using the Terminal route. Please open Terminal.app and past the following command and past the output into this discussion.

    gpg2 --keyserver hkp://keys.gnupg.net --search-keys mento
    

    Let me know your findings,
    steve

  2. Support Staff 2 Posted by Steve on 04 Jun, 2014 04:28 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  3. Steve closed this discussion on 04 Jun, 2014 04:28 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac