OSX 10.9.2 Broke GPGMail plug-in

eewarlord's Avatar

eewarlord

25 Feb, 2014 07:14 PM

After installing the 10.9.2, launching Mail displays a message that the GPGMail plug-in is not comparable and disables it.

Are there any tweaks I can do to allow the plugin to work? If not, Is there a new build in the works?

I'm running what I believe to be the newest "nightly" builds:
GPGMail = 2.01 - build 621n GPG KCA = 1.1.2 - build 655n GPGServices = 1.9.1 - build 612n MacGPG2 = 2.0.22 - build 629n GPG Pref = 1.0.2 - build 591n

  1. 1 Posted by matti on 25 Feb, 2014 10:00 PM

    matti's Avatar

    Please reinstall the package "GPG Suite - 2013.10.22.dmg" from https://gpgtools.org/#gpgsuite and GPGMail run perfect.

  2. Support Staff 2 Posted by Steve on 25 Feb, 2014 10:26 PM

    Steve's Avatar

    What matti says. Please let us know if that solves the problem for you.

    Best :)
    steve

  3. 3 Posted by eewarlord on 25 Feb, 2014 10:51 PM

    eewarlord's Avatar

    Unfortunately, that has not fixed it. I still get the same error dialog box (... not comparable with Mail 7..2)

    Unfortunately, re-installing "GPG Suite - 2013.10.22.dmg" just results in the same error when I launch Mail. (I've attached the screen cap - although i'm sure you folks know exactly what it looks like.)

    For the record, even before upgrading to 10.9.2, the 10.22 build refused to work with MacMail on my machine. I was successful with the later builds (which is why I was using the nightlies).

    So, after the re-installing the 10.22 build failed - I tried re-installing with the build I was using before the update 10.9.2 update. Sadly, this didn't fix it either.

    Do I need to backup my keys and completely uninstall GPG tools and THEN reinstall?

    Any other tips?

    Thanks.

  4. 4 Posted by K. M. Peterson on 25 Feb, 2014 10:58 PM

    K. M. Peterson's Avatar

    I had the same problem.

    What I found (file this under: worked for me) is that some mailbundles get installed in ~/Library/Mail/Bundles, and some in /Library/Mail/Bundles - the latter being a system directory. I had to clean out both locations and reinstall. Once I'd done that, I'm running again. This is also true for a couple of other products that broke today as well.

    Hope this helps.

  5. 5 Posted by eewarlord on 26 Feb, 2014 12:33 AM

    eewarlord's Avatar

    Thanks for all the tips and feedback.

    Unfortunately, I've tried all of the tips listed above, and even uninstalled / rebooted / reinstalled with three different builds that I have, and it still fails every time. I've listed the details below.

    At this point, I have no idea what more I can do, short of wiping the machine and doing a clean install of OSX. Anyone have any other thoughts or ideas?

    K.M. Peterson - thanks for your tips. here's what I found:

    /Library/Mail/Bundles contained GPGMail.mailbundle
      - I believe the bundle disappeared during the uninstalls i performed below
      - If not, I manually deleted it.
    ~/Library/Mail did not have a Bundles directory.
    The only sub-directory was named V2, The V2 subdirectory did not contain any mailbundles.

    Here'e the troubleshooting process I went through:

    Re-install #1
    - Ran the un-installer included in the dmg
    - rebooted
    - re-installed "GPG Suite - 2013.10.22.dmg" 
    - Ran GPG Keychain Access to verify installation & it worked fine, 
    - Launched Mail and got the same error dialog 
    
    I repeated the process a second time, using a build i had downloaded in Jan
    (the file size of the DMG is 22.4MB)
    - ran the un-installer included in the "10.22" dmg, 
    - rebooted
    - re-installed with the package I was using prior to updating to 10.9.2
      Not sure of the build date - but the package size is 22.4MB.
    - Ran GPG Keychain Access to verify installation & it worked fine, 
    - Launched Mail and got the same error dialog
    
    I repeated the process a third time, using a build i had downloaded in early Feb
    (the file size of the DMG is 23.8MB)
    - Ran the un-installer included in the "22.4MB" dmg (for lack of a better name) 
    - rebooted
    - re-installed with the "23.8MB' dmg
    - Ran GPG Keychain Access to verify installation & it worked fine, 
    - Launched Mail and got the same error dialog
    
  6. Support Staff 6 Posted by Luke Le on 26 Feb, 2014 10:01 AM

    Luke Le's Avatar

    Hi K.M.,

    we apologize sincerely for the troubles you're having.
    It's really strange you can't get it running.
    Could you please try to install the nightly if you haven't done so already?
    https://releases.gpgtools.org/nightlies/GPG%20Suite-latest.dmg

    If that doesn't work, we'll certainly find another way to get you back on your original setup.

  7. Support Staff 7 Posted by Luke Le on 26 Feb, 2014 10:22 AM

    Luke Le's Avatar

    Hi K.M.,

    please only try the uninstalling if the following steps don't work (since preferences are also uninstalled by the uninstaller):

    1.) Download nightly GPG Suite
    2.) Install GPG Suite
    3.) Don't open Mail and logout
    4.) Log back in and check if Mail + GPGMail works

  8. 8 Posted by K. M. Peterson on 26 Feb, 2014 02:50 PM

    K. M. Peterson's Avatar

    Luke:

    Actually, eewarlord is having difficulties, not I. Thanks, thought!

    eewarlord:

    I'd go with Luke's suggestion and try a nightly build. It really does seem on some level like the "wrong" bundle is in there somehow. Another thing to do would be to verify the date on the actual GPGMail.mailbundle file - mine is 22Oct13 - to be sure it's the same code. Good luck!

  9. Support Staff 9 Posted by Luke Le on 26 Feb, 2014 03:05 PM

    Luke Le's Avatar

    Oh sorry, my bad.

  10. 10 Posted by eewarlord on 26 Feb, 2014 06:28 PM

    eewarlord's Avatar

    It is fixed!

    The ultimate cause of the problem was Mail.app was not in my Applications folder. Once I moved it to the Applications folder and re-installed, it worked! I'll accept responsibility for causing this problem. Had I remembered moving the app, I would have put it back in the Applications folder & re-installed GPGTools before trying anything else. (We can call this stupid user error.)

    My guess is that during install GPGTools fetches the PluginCompatibilityUUID from Mail's Info.plist, and copies it to the SupportedPluginCompatibilityUUIDs list in GPGMail's Info.plist.

    I suspect this process assumes that Mail.app is in the Applications folder. If it's not, then it can't get the new UUID from Mail's info.plist. Thus, it can't update it's own plist for compatibility.

    I'd like to make a few suggestions, which may benefit the community, should this scenario arise again:
    - When troubleshooting GPGMail problems, verify the user hasn't moved Mail.app out of the Applications folder.
    - Also, perhaps the GPG Installer could log an error if it's unable to locate Mail.app during setup.

    Thank you everyone for your help!

  11. Support Staff 11 Posted by Luke Le on 26 Feb, 2014 06:31 PM

    Luke Le's Avatar

    Oh damned, of course that is the problem.
    Didn't of it.
    I'll file a bug so we'll make it possible that Mail can be anywhere (in theory at least)

    Thanks for finding this bug and sorry for the troubles again.

  12. 12 Posted by eewarlord on 26 Feb, 2014 10:00 PM

    eewarlord's Avatar

    Thank you for submitting a bug on this!

    I do have a followup question as a result of the troubleshooting I did earlier:

    I was alarmed to see my PGP Keys still intact in Keychain Access after I had performed about a dozen un-installs and re-installs (using the un-installer in the DMG). I was under the impression that keys and data would be deleted during the un-install process.

    Where is the PGP Key data stored? Is there other data & configuration information that remains after an un-install? If you aren't sure exactly what data remains, can you share the locations that the suite stores data, so we can write a script?

    There are scenarios were people want to completely remove all traces of PGP from their computer. Ideally, it would be great if the un-installer gave users an option to do this.

    Thanks for any info you can share!

  13. Support Staff 13 Posted by Luke Le on 26 Feb, 2014 10:07 PM

    Luke Le's Avatar

    I think you'd probably come over and kill us if we did delete your keys.
    But in all seriousness, an option to pick what to uninstall is a good idea, and we've actually already talked about that internally and will add it.
    Currently everything but the keys are removed, so any preferences.
    Locations are many but the most complete list can be found in our uninstaller script:
    https://raw.github.com/GPGTools/GPGTools_Installer/266c3c5602ff82f1...

    Your gnupg keys and gnupg related configurations are located in a hidden directory (we stick to the gnupg default for the time being) in your home folder. It's called .gnupg

  14. 14 Posted by eewarlord on 26 Feb, 2014 10:45 PM

    eewarlord's Avatar

    Perfect! That script is exactly what I was looking for.

    Thanks for the info about everything getting deleted except the keys. I do wonder - what's the value in not deleting the keys if they are in a hidden directory that the user doesn't know about? At that point, aren't they essentially deleted as far as the user knows anyway? If they're savvy enough to find the hidden directory, their probably savvy enough to have key backups.

    Personally, I find the risk of having private keys remaining on a computer when you think they're delete a far bigger risk.

    I expected the keys to be deleted and backed them up before un-installing. Which reminds me - it would be really nice to have a "backup keychain" option. I couldn't find an easy way to do this, and had to backup my keys one-by-one - which was a pain.

    Thank you again, and I'll stop with the feature requests now ;-)

  15. Support Staff 15 Posted by Luke Le on 26 Feb, 2014 10:53 PM

    Luke Le's Avatar

    The decision of not deleting them by default was formed by our experience with users. Too many times some removed GPGTools, and re-installed it shortly after or after a some time, and were very happy to see the keys were still there or could locate them on a backup.
    A backup feature is very very high on our priority list, but I absolutely agree that it should be possible to remove the keys as well. That's why the uninstaller will include such an option in the future.

  16. Support Staff 16 Posted by Steve on 12 Mar, 2014 01:15 PM

    Steve's Avatar

    FYI: https://gpgtools.lighthouseapp.com/projects/65764-gpgmail/tickets/725 is fixed.

    I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  17. Steve closed this discussion on 12 Mar, 2014 01:15 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac